Bug 1464867 - ovn-controller is not configured to start at boot
ovn-controller is not configured to start at boot
Status: CLOSED DUPLICATE of bug 1466169
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openvswitch (Show other bugs)
7.4
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Lance Richardson
ovs-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-26 02:25 EDT by Mor
Modified: 2017-06-29 04:16 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-29 04:16:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mor 2017-06-26 02:25:37 EDT
Description of problem:
ovn-controller service is not shipped as enabled (to start at boot), by thus can cause a VM to fail if it has OVN network attached to it after a reboot to the hypervisor.

Version-Release number of selected component (if applicable):
openvswitch-2.7.0-1.el7.x86_64
openvswitch-ovn-host-2.7.0-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. on hypervisor, run yum install openvswitch-ovn-host
2. systemctl status ovn-controller

Actual results:
Loaded: loaded (/usr/lib/systemd/system/ovn-controller.service; disabled; vendor preset: disabled)

Expected results:
ovn-controller should be enabled by the RPM installation.
Comment 2 Lance Richardson 2017-06-26 08:25:31 EDT
My understanding of packaging guidelines is that only services that do not
require configuration to be functional may be enabled by default. Since
ovn-controller requires configuration in order to be functional, it should
not be enabled by default. See e.g.:

    https://fedoraproject.org/wiki/Packaging:DefaultServices

Your application must already be doing the equivalent of "systemctl start
ovn-controller" in order to use this service, is there a reason it cannot
also do "systemctl enable ovn-controller"?

Thanks,

  Lance
Comment 3 Mor 2017-06-26 09:01:09 EDT
Dan, could you answer this?  On hypervisors - can we change the code of the hook(s) to start ovn-controller service?

Currently, the only thing that triggers ovn-controller start is vdsm-config, which is only used only once during setup of the environment.
Comment 4 Flavio Leitner 2017-06-28 08:24:43 EDT
We also don't enable OVS by default.
Comment 5 Dan Kenigsberg 2017-06-28 16:38:25 EDT
I agreed with Lance. Services should not be enabled by default, without a very good reason.

The bug should have been filed on ovirt-provider-ovn-driver.
Comment 6 Mor 2017-06-29 04:16:24 EDT

*** This bug has been marked as a duplicate of bug 1466169 ***

Note You need to log in before you can comment on or make changes to this bug.