Bug 1464883 - Cannot start qupzilla - relocation error (QtWebEngine binary compatibility breakage in 5.9.0)
Cannot start qupzilla - relocation error (QtWebEngine binary compatibility br...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt5-qtwebengine (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kevin Kofler
Fedora Extras Quality Assurance
:
: 1465033 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-26 03:49 EDT by Mattia Verga
Modified: 2017-07-25 16:57 EDT (History)
8 users (show)

See Also:
Fixed In Version: qt5-qtwebengine-5.9.0-4.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-27 23:02:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Qt Bug Tracker QTBUG-61521 None None None 2017-06-26 16:42 EDT

  None (edit)
Description Mattia Verga 2017-06-26 03:49:19 EDT
Fresh new Rawhide installation, when I try to open Qupzilla I get:

qupzilla: relocation error: /lib64/libQupZilla.so.2: symbol free, version Qt_5 not defined in file libQt5WebEngineCore.so.5 with link time reference
Comment 1 Kevin Kofler 2017-06-26 04:43:06 EDT
I am already aware of this (see the comments in the F26 Bodhi update), and have a proposed fix.

Can you please try:
https://koji.fedoraproject.org/koji/buildinfo?buildID=911295
?

(If you also have the freeworld package, you'll also want:
http://koji.rpmfusion.org/koji/buildinfo?buildID=4293
which will hopefully be done soon at least for x86, or you can temporarily uninstall qt5-qtwebengine-freeworld.)
Comment 2 Mattia Verga 2017-06-26 05:17:49 EDT
After the upgrade of qt5-qtwebengine-5.9.0-3.fc27 launching Qupzilla it gets stuck at "QupZilla: Creating new profile directory"
Comment 3 Kevin Kofler 2017-06-26 05:44:24 EDT
So the symbol issue seems fixed, but the new issue is all the weirder. I am not sure where exactly it hangs, because the code that creates the profile directory does not write anything when done, so it is likely that the actual issue actually happens much later. Have you tried restarting the session after upgrading QtWebEngine? (There may be some hung background processes from the old QupZilla runs that may interfere otherwise.)
Comment 4 Kevin Kofler 2017-06-26 09:05:12 EDT
*** Bug 1465033 has been marked as a duplicate of this bug. ***
Comment 5 Kevin Kofler 2017-06-26 09:06:00 EDT
Workaround for F26 users:
sudo dnf --disablerepo=updates-testing distro-sync qt5-qtwebengine
Comment 6 Rex Dieter 2017-06-26 11:32:30 EDT
For what it's worth, I cannot reproduce the "qupzilla gets stuck" issue on f25
Comment 7 clxcoltz 2017-06-26 12:05:36 EDT
On F26 / updates-testing, this only happens after upgrading to Qt5.9. I've worked around by downgrading QtWebEngine as mentioned above and now Qupzilla works again.
Comment 8 Kevin Kofler 2017-06-26 16:42:38 EDT
I debugged the issue from comment #2: The problem is the linker (or the dynamic linker?) ends up picking my realloc@Qt_5 to resolve realloc calls within QtWebEngine, which then ends up calling itself (for the same reason), hanging the process in an infinite loop of tailcalls. (There is no stack overflow because the calls are tailcall-optimized.)

I think I need this fix:
https://codereview.qt-project.org/#/c/198545/
from upstream https://bugreports.qt.io/browse/QTBUG-61521 – I'll try a new build.

Interestingly, a scratch build for F26 that I did with the same patch as in Rawhide appears to work. Weird. Still, I'll do the official F26 build with the updated patches.
Comment 9 Kevin Kofler 2017-06-26 19:46:03 EDT
Try this one: https://koji.fedoraproject.org/koji/buildinfo?buildID=912065
Comment 10 Mattia Verga 2017-06-27 03:33:19 EDT
Forgive me for the delay, I was out for work.

So, I can confirm that the latest update to qt5-qtwebengine-5.9.0-4.fc27 fixes the problem. Qupzilla is now working again.

Thanks!
Comment 11 Kevin Kofler 2017-06-27 23:02:28 EDT
This is fixed in Rawhide in qt5-qtwebengine-5.9.0-4.fc27. I also edited the Fedora 26 testing update https://bodhi.fedoraproject.org/updates/FEDORA-2017-e83c26a8c9 with a fixed build (qt5-qtwebengine-5.9.0-4.fc26).

Note You need to log in before you can comment on or make changes to this bug.