Bug 1465390 - python3-pyldap break FreeIPA WebUI
python3-pyldap break FreeIPA WebUI
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-pyldap (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
:
Depends On:
Blocks: BetaBlocker/F27BetaBlocker
  Show dependency treegraph
 
Reported: 2017-06-27 07:13 EDT by Stanislav Laznicka
Modified: 2017-09-09 00:11 EDT (History)
8 users (show)

See Also:
Fixed In Version: python-pyldap-2.4.37-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-09 00:11:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stanislav Laznicka 2017-06-27 07:13:18 EDT
Description of problem:
Latest package of python3-pyldap breaks FreeIPA WebUI as it contains python3-incompatible code.

Version-Release number of selected component (if applicable):
python-pyldap-2.4.35.1-2.fc26

How reproducible:
100%

Steps to Reproduce:
1. Install latest master of FreeIPA with some patches that are not currently available (sorry, guys!)
2. Try to log in to the WebUI

Actual results:
Internal server error.

Expected results:
Getting the page after login.

Additional info:
The fixes below seem to fix the issues:
https://github.com/pyldap/pyldap/pull/104
https://github.com/pyldap/pyldap/commit/60801268c56784f86847caa400dc0aad1699eb26
Comment 1 Miro Hrončok 2017-06-27 08:50:08 EDT
Will wait how that PR resolves upstream.
Comment 2 Miro Hrončok 2017-06-28 08:40:14 EDT
Will update to https://pypi.python.org/pypi/pyldap/2.4.37
Comment 3 Miro Hrončok 2017-06-28 09:20:45 EDT
The tests are failing with Can't contact LDAP server

https://koji.fedoraproject.org/koji/taskinfo?taskID=20226499
Comment 4 Stanislav Laznicka 2017-08-15 03:39:40 EDT
Would it be possible to try and test with a newer python-ldap version, then? I noticed upstream had some more python3 fixes.
Comment 5 Stanislav Laznicka 2017-08-17 04:56:09 EDT
My bad, there are no newer versions than that, sorry.
Comment 6 Petr Viktorin 2017-08-21 07:51:00 EDT
Tests are failing for the new version, but also for the old one (which built successfully before). Probably due to a change in Koji or a dependency.

Investigating this is on my TODO list, but unfortunately, modularity has higher priority now.
Comment 7 Adam Williamson 2017-09-05 15:31:44 EDT
The test failures seem to be somewhat randomized; for each recent attempt to build, it's worked on some arches but not on others. Interestingly the test *order* doesn't always seem to be the same, which may have something to do with why the tests sometimes fail.

Proposing this as a Fedora 27 Beta blocker. A Beta criterion states:

"The core functional requirements for all Featured Server Roles must be met, without any workarounds being necessary."

And one of the 'core functional requirements' for the domain controller role, which is a featured role, is:

"The FreeIPA configuration web UI must be available and allow at least basic configuration of user accounts and permissions"

See https://fedoraproject.org/wiki/Domain_controller_role_requirements and https://fedoraproject.org/wiki/Fedora_27_Beta_Release_Criteria#Server_Product_requirements .

I'm going to keep poking this a bit more, but it looks like Igor Gnatenko just went ahead and ran a Rawhide build with the tests turned off...we might have to do the same for F27.
Comment 8 Adam Williamson 2017-09-05 16:26:12 EDT
So I'm pretty sure the ordering problem here is: if the t_cext tests run after the t_ldapobject tests, they will fail. I verified this by simply adjusting the spec to remove the t_ldapobject tests entirely, and running a scratch build - it passes on all arches. I'm now trying to narrow it down a bit more specifically.
Comment 9 Adam Williamson 2017-09-05 17:56:50 EDT
OK, I believe I figured out the problem. PR sent upstream:

https://github.com/pyldap/pyldap/pull/122

and I've applied the fix to the package, re-enabled the tests, and sent builds for Rawhide and F27. I'll be adding the F27 package to the pending FreeIPA 3.6.0 update.
Comment 10 Fedora Update System 2017-09-05 17:58:55 EDT
389-ds-base-1.3.7.3-1.fc27 freeipa-4.6.0-1.fc27 python-pyldap-2.4.37-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a79e85e4d3
Comment 11 Adam Williamson 2017-09-05 18:27:22 EDT
Indeed, the openQA webui test passes with the edited update:

https://openqa.stg.fedoraproject.org/tests/154667

there seems to still be an issue with password changing, though. Will investigate that next.
Comment 12 Fedora Update System 2017-09-07 10:30:10 EDT
389-ds-base-1.3.7.3-1.fc27, freeipa-4.6.0-2.fc27, python-pyldap-2.4.37-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a79e85e4d3
Comment 13 Fedora Update System 2017-09-09 00:11:07 EDT
389-ds-base-1.3.7.3-1.fc27, freeipa-4.6.0-2.fc27, python-pyldap-2.4.37-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.