Bug 146542 - bad dependencies: python-devel breaks yum(non-devel)
bad dependencies: python-devel breaks yum(non-devel)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-29 08:13 EST by Patrick von der Hagen
Modified: 2014-01-21 17:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 14:35:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Patrick von der Hagen 2005-01-29 08:13:29 EST
After upgrading python to devel (python 2.4) yum stopped working and
failed to "import yumain". Installing a new yum-rpm from devel fixed
that problem, but "import rpm" failed. After upgrading rpm-python,
everything works fine again.

Obviously, the dependencies of yum, rpm-python and python are not
specified correctly. Since I considere it the yum-maintainers
responsibility to specify the yum-dependencies, I file this bug here.
My older yum-package should have specified that it depends on a
certain python-release. Since that can't be fixed now anymore one
might argue that the new python-package has to specify the conflict to
prevent yum from breaking.

However, I believe the yum-maintainer should be responsible to
organise the yum-dependencies either way. Next yum-rpms should state
their dependencies correctly to prevent future problems. See bug
114059 for more information.

Sadly, such python-dependency-problems are not seen for the first
time, compare Bug 138692.

It would be great if those dependency-issues could be fixed permanently.
Comment 1 Seth Vidal 2005-07-29 14:35:16 EDT
current release targets a specific python-abi
closing

Note You need to log in before you can comment on or make changes to this bug.