Bug 1465548 - webadmin: Missing fields in 'Edit Provider' dialog for KVM, XEN and VMware provider types
webadmin: Missing fields in 'Edit Provider' dialog for KVM, XEN and VMware pr...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-4.2.1
: ---
Assigned To: Sharon Gratch
Pavel Novotny
:
: 1507490 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-27 11:24 EDT by Sharon Gratch
Modified: 2018-02-12 06:55 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-02-12 06:55:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tjelinek: ovirt‑4.2?
pnovotny: testing_plan_complete-
tjelinek: planning_ack?
rule-engine: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 85748 master MERGED webadmin: Add missing fields in 'Edit Provider' dialog 2017-12-29 15:35 EST

  None (edit)
Description Sharon Gratch 2017-06-27 11:24:22 EDT
Description of problem:
The 'Edit provider' dialog (WebAdmin->Administration->Providers->edit) for XEN, VMware and KVM is displayed with only part of the required fields. 

The following fields are missing and therefore can't be edited:
KVM, XEN: "URI", "Proxy Host"
VMware:   "Vcenter", "ESXi", "Data Center" (of VMware), "Cluster", "Verify server's SSL certificate", "Proxy host".


Version-Release number of selected component (if applicable):
4.2 master, commit 8491a8e

How reproducible:
100%

Steps to Reproduce:
1. Go in WebAdmin to Administration->Providers
2. Choose one of the existed providers of type KVM, Xen or VMware and click 'Edit'

Actual results:
The "Edit Provider' dialog is displayed with part of the required fields

Expected results:
The "Edit Provider' dialog should be displayed with all relevant editable/non-editable fields.
Comment 1 Tomas Jelinek 2017-06-28 06:34:11 EDT
Interesting, in new dialog they are there and in edit not. Can you please check on some env around you if it is missing also on 4.1?
Comment 2 Sharon Gratch 2017-06-28 08:23:10 EDT
(In reply to Tomas Jelinek from comment #1)
> Interesting, in new dialog they are there and in edit not. Can you please
> check on some env around you if it is missing also on 4.1?

on 4.1.3 there is no such a problem (no field is missing)
Comment 3 Tomas Jelinek 2017-06-29 06:15:42 EDT
the reason why is it not working in 4.2 is that:

- the ProviderModel in callback of getType().getSelectedItemChangedEvent() sets the getKvmPropertiesModel().setIsAvailable(isKvm);
- the default value of this the isAvailable is true and setting it again to true does not trigger the propertyChangeEvent
- consequently, the e.g. KVMPropertiesModel's getPropertyChangedEvent().addListener's callback is not triggered and the proxyHost and url is not inited.
- similarly for all the other models

The fact it worked on 4.1 is I'd say relying on some mistake in the Model - so keeping in virt and targeting 4.2
Comment 4 Tomas Jelinek 2017-10-30 11:36:05 EDT
*** Bug 1507490 has been marked as a duplicate of this bug. ***
Comment 5 Pavel Novotny 2018-01-17 14:15:58 EST
Verified in
ovirt-engine-4.2.1.1-0.1.el7.noarch
ovirt-engine-webadmin-portal-4.2.1.1-0.1.el7.noarch

All fields in the Add Provider dialog are shown and editable (except for `Type` field) also in the Edit Provider dialog.

Verified for provider types KVM, XEN, VMware as well as Foreman/Satellite and OpenStack *.
Comment 6 Sandro Bonazzola 2018-02-12 06:55:38 EST
This bugzilla is included in oVirt 4.2.1 release, published on Feb 12th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.1 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.