Bug 146580 - Paste in Calc shifts cells by default
Summary: Paste in Calc shifts cells by default
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org   
(Show other bugs)
Version: 3
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dan Williams
QA Contact:
URL:
Whiteboard:
Keywords:
: 146872 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-01-29 23:29 UTC by Steve Hall
Modified: 2007-11-30 22:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-11 21:27:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steve Hall 2005-01-29 23:29:06 UTC
Description of problem:

The default paste behavior in Calc shifts cells, which is both
non-standard and unseen in the previous release. (And is redundant
with an option provided in Paste Special.)

Version-Release number of selected component (if applicable):

1.1.3 Calc

Comment 1 Dan Williams 2005-01-31 17:57:12 UTC
confirmed, this was caused by an upstream ooo-build patch added by
Novell that we'll have to disable.

Comment 2 Dan Williams 2005-01-31 17:57:56 UTC
Specific changelog entry is:

2005-01-27  Michael Meeks  <michael.meeks@novell.com>

	* patches/OOO_1_1_4/apply, patches/OOO_1_1_3/apply:
	disable sc-paste-insert-rows.diff, very odd / unexpected
	behavior hurting users.



Comment 3 JLapham 2005-02-01 12:24:12 UTC
Dan, I just stumbled across this bug as well, any plans to re-release?  

This bug makes using calc basically useless, I totally screwed up a complex
spreadsheet layout today as parts of columns and rows got pushed around during a
series of pastes... ugh.

Comment 4 Ian Pilcher 2005-02-01 17:55:12 UTC
Shouldn't this be high priority?

Comment 5 Steve Hall 2005-02-02 02:30:08 UTC
Ian, agreed, although I can't prioritize. :)

How about we just bump up the severity as this is a nearly
incapacitating behavior/bug.


Comment 6 Caolan McNamara 2005-02-02 13:46:36 UTC
*** Bug 146872 has been marked as a duplicate of this bug. ***

Comment 7 Elson, Del 2005-02-03 23:30:38 UTC
Confirmed that this bug appears on multiple distributions, see:
http://www.openoffice.org/issues/show_bug.cgi?id=40204

Oddly enough the OOo folks don't appear to think it's their problem. 
Somebody hit them with a clue stick please.


Comment 8 Dan Williams 2005-02-04 00:54:29 UTC
Technically its not their problem as the code is a patch in the
ooo-build sources.  Vendors like Red Hat, Novell, Suse, and Debian use
common sources and patches from ooo-build.

Comment 9 Ian Pilcher 2005-02-07 20:59:39 UTC
Wasn't there a plan to have an update out late last week?

Comment 10 Dan Williams 2005-02-07 21:27:18 UTC
Build is pushed to rawhide already, and an FC-3 updates-testing build
will be available soon... (its built already and needs to be mirrored)


Comment 11 JLapham 2005-02-08 02:02:36 UTC
Dan, is this new build going to also fix the "cannot unhide a row"
regression?

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=146758


Comment 12 Dan Williams 2005-02-10 14:15:04 UTC
No, unfortunately, that's a separate beast... :(  Hopefully next
update after this one.

Comment 13 Mike Cotton 2005-02-11 19:12:42 UTC
Dan,

Can you give us a guestimate as to when the FC3 patch will be released?  

Many Thanks. 

Comment 14 Dan Williams 2005-02-11 21:27:10 UTC
Its been pushed and will trickle out to mirrors in the next 24 hours
or so.

openoffice.org-1.1.3-5.5.0.fc3

Comment 15 Jan Slupski 2005-02-20 14:46:24 UTC
Please check if bug 146883 is not related. It have appeared in the
same release, and is also very painful.

Comment 16 Dan Williams 2005-02-20 15:46:51 UTC
No, bug 146883 is not related.


Note You need to log in before you can comment on or make changes to this bug.