Bug 1465857 - Unable to add an ansible playbooks repository
Unable to add an ansible playbooks repository
Status: CLOSED NOTABUG
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.8.0
All All
high Severity high
: GA
: 5.8.1
Assigned To: James Wong
Dmitry Misharov
ansible_embed:playbook:repo
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-28 07:40 EDT by Dmitry Misharov
Modified: 2017-07-27 10:14 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-30 02:16:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Ansible


Attachments (Terms of Use)

  None (edit)
Description Dmitry Misharov 2017-06-28 07:40:23 EDT
Description of problem:
The issue is related to https://bugzilla.redhat.com/show_bug.cgi?id=1452584. It seems the UI part of the issue was fixed, but backend part is still there. If you try to add an ansible playbooks repository with git url it will be accepted by the UI but the status will be "failed".

Version-Release number of selected component (if applicable):
5.8.1.0.20170623170756_3ed4411 

How reproducible:
Always

Steps to Reproduce:
1. Enable Embedded Ansible Role.
2. Navigate to Automation/Ansible/Repositories.
3. Fill "Name" field. In URL field write "git@github.com:jonnyfiveiq/Ansible_Playbooks"
4. Click "Add" button.

Actual results:
The repository is appeared in the UI, but status is "Failed" and no playbooks 
are added.

Expected results:
Playbooks from the repo should be appeared in the UI and status of the repo should be "Successful"

Additional info:
Comment 2 James Wong 2017-06-28 10:45:04 EDT
Dmitry,

Can you provide evem.log?

thanks,
James
Comment 5 Dmitry Misharov 2017-06-30 02:16:50 EDT
Thanks, John. it worked. I'm closing it as not a bug.

Note You need to log in before you can comment on or make changes to this bug.