Bug 1466073 - subsystem-cert-update command lacks --cert option
subsystem-cert-update command lacks --cert option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core (Show other bugs)
7.4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: RHCS Maintainers
Asha Akkiangady
: ZStream
Depends On:
Blocks: 1469437
  Show dependency treegraph
 
Reported: 2017-06-28 20:00 EDT by Matthew Harmsen
Modified: 2018-04-10 13:01 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
If this bug requires documentation, please select an appropriate Doc Type value.
Story Points: ---
Clone Of:
: 1469437 1487225 (view as bug list)
Environment:
Last Closed: 2018-04-10 13:00:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0925 None None None 2018-04-10 13:01 EDT

  None (edit)
Description Matthew Harmsen 2017-06-28 20:00:46 EDT
Currently, the `--cert <filename>` and `--overwrite` options for `pki-server subsystem-cert-update` command hasn't been implemented. This command automates the importing of the certificate passed as argument into NSS database and overwrites the existing one.  Also, necessary changes are made in the `CS.cfg` file.

Reference: http://pki.fedoraproject.org/wiki/System_Certificate_Renewal#PKI_10.4_or_later_2
Comment 2 Endi Sukma Dewata 2017-06-30 00:41:12 EDT
Fixed in master:
* https://github.com/dogtagpki/pki/commit/d762073c4b5bcd4f9f30e3b8439983a497a77c97
Comment 5 Amol K 2018-01-10 05:10:37 EST
I tested this on the PKI 10.5.1-5.el7 version.

I used following steps to verify this bug:

Upgrading subsystem certificate.

1. pki -d /opt/pki/certdb/ -c Secret123 -p 20080  ca-cert-request-submit --profile caManualRenewal --serial 0x4 --renewal

2. pki -d /opt/pki/certdb/ -c Secret123 -p 20080 -n "PKI CA Administrator for Example.Org" ca-cert-request-review --action approve <request_id>

3. pki -d /opt/pki/certdb/ -c Secret123 -p 20080 cert-show <cert_id> --output subsystem_cert.crt

4. pki-server subsystem-cert-update ca subsystem -i topology-02-CA --cert subsystem_cert.crt

5. certutil -L -d /var/lib/pki/topology-02-CA/alias/ -n "subsystemCert cert-topology-02-CA" # For verification of subsystem cert is updated in the database.

Restart the instance.

If the instance is started successfully then the certificate is updated successfully.

Verifying this bug.
Comment 11 errata-xmlrpc 2018-04-10 13:00:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0925

Note You need to log in before you can comment on or make changes to this bug.