Bug 1469437 - subsystem-cert-update command lacks --cert option
subsystem-cert-update command lacks --cert option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pki-core (Show other bugs)
7.4
All Linux
urgent Severity urgent
: rc
: ---
Assigned To: Dinesh Prasanth
Asha Akkiangady
: ZStream
Depends On: 1466073
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 05:28 EDT by Jaroslav Reznik
Modified: 2017-09-05 07:25 EDT (History)
6 users (show)

See Also:
Fixed In Version: pki-core-10.4.1-12.el7_4
Doc Type: No Doc Update
Doc Text:
This will be used and documented in a later release.
Story Points: ---
Clone Of: 1466073
Environment:
Last Closed: 2017-09-05 07:25:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Reznik 2017-07-11 05:28:43 EDT
This bug has been copied from bug #1466073 and has been proposed to be backported to 7.4 z-stream (EUS).
Comment 3 Amol K 2017-08-10 08:12:54 EDT
I tested this bug on pki 10.4.1-12.el7_4 build.

Steps i perform to test:

1. Created the certificate request using certutil and /var/lib/pki/topology-02-CA/alias directory.
2. Submitted the certificate request using pki command and caOCSPCert profile and /var/lib/pki/topology-02-CA/alias directory..
3. Approve the certificate request, Save the certificate in the file. 
4. Change the OCSP server certificate with the following command:

~ # pki-server subsystem-cert-update ca ocsp_signing -i topology-02-CA --cert /tmp/ocsp_cert.pem 

5. Restart the CA instance.

CA instance is started successfully.

Verifying this bug.
Comment 5 errata-xmlrpc 2017-09-05 07:25:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2575

Note You need to log in before you can comment on or make changes to this bug.