Bug 1466181 - ovn-controller is not configured to start at boot
ovn-controller is not configured to start at boot
Status: CLOSED CURRENTRELEASE
Product: ovirt-provider-ovn
Classification: oVirt
Component: driver (Show other bugs)
1.0.4
Unspecified Unspecified
high Severity high
: ovirt-4.2.0
: ---
Assigned To: Marcin Mirecki
Mor
:
: 1466169 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-06-29 04:28 EDT by Mor
Modified: 2017-12-20 06:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:10:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 78941 master MERGED ovn-controller must start at boot 2017-07-10 03:41 EDT

  None (edit)
Description Mor 2017-06-29 04:28:35 EDT
Description of problem:
ovn-controller service is not shipped as enabled (to start at boot), by thus can cause a VM to fail if it has OVN network attached to it after a reboot to the hypervisor.

Version-Release number of selected component (if applicable):
openvswitch-2.7.0-1.el7.x86_64
openvswitch-ovn-host-2.7.0-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. on hypervisor, run yum install openvswitch-ovn-host
2. systemctl status ovn-controller

Actual results:
Loaded: loaded (/usr/lib/systemd/system/ovn-controller.service; disabled; vendor preset: disabled)

Expected results:
ovn-controller should be enabled by the RPM installation.
Comment 1 Mor 2017-06-29 04:29:10 EDT
*** Bug 1466169 has been marked as a duplicate of this bug. ***
Comment 2 Mor 2017-07-13 07:39:41 EDT
Verified on:
ovirt-provider-ovn-driver-1.1-2.20170710074946.git5abef7f.el7.centos.noarch

# vdsm-tool ovn-config <central_ip> <tunneling ip>

Using default PKI files
Created symlink from /etc/systemd/system/multi-user.target.wants/openvswitch.service to /usr/lib/systemd/system/openvswitch.service.
Created symlink from /etc/systemd/system/multi-user.target.wants/ovn-controller.service to /usr/lib/systemd/system/ovn-controller.service.

# systemctl status ovn-controller
ovn-controller.service - OVN controller daemon
   Loaded: loaded (/usr/lib/systemd/system/ovn-controller.service; enabled; vendor preset: disabled)
   Active: active (exited) since Thu 2017-07-13 14:36:31 IDT; 11s ago
  Process: 10303 ExecStart=/usr/share/openvswitch/scripts/ovn-ctl start_controller $OVN_CONTROLLER_OPTS (code=exited, status=0/SUCCESS)
 Main PID: 10303 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/ovn-controller.service
           ├─10328 ovn-controller: monitoring pid 10329 (healthy)
           └─10329 ovn-controller unix:/var/run/openvswitch/db.sock -vconsole:emer -vsyslog:err -vfile:info --private-key=/etc/pki/vdsm/keys/vdsmkey.pem --certificate=/etc/pki/vdsm/certs/vdsmcert.pem --ca-cer...

# systemctl status openvswitch.service 
openvswitch.service - Open vSwitch
   Loaded: loaded (/usr/lib/systemd/system/openvswitch.service; enabled; vendor preset: disabled)
   Active: active (exited) since Thu 2017-07-13 14:36:31 IDT; 20s ago
  Process: 10166 ExecStop=/bin/true (code=exited, status=0/SUCCESS)
  Process: 10300 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
 Main PID: 10300 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/openvswitch.service
Comment 3 Sandro Bonazzola 2017-12-20 06:10:38 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.