Bug 1467140 - Warning message: Unable to find iscsi record for ...session1 when start kdump service
Warning message: Unable to find iscsi record for ...session1 when start kdump...
Status: CLOSED DUPLICATE of bug 1265046
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kexec-tools (Show other bugs)
7.5
Unspecified Linux
medium Severity medium
: rc
: ---
Assigned To: kdump team
Qiao Zhao
:
Depends On:
Blocks: 1473055
  Show dependency treegraph
 
Reported: 2017-07-02 23:02 EDT by Qiao Zhao
Modified: 2017-07-19 23:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-19 23:01:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qiao Zhao 2017-07-02 23:02:46 EDT
Description of problem:
I met some warning message when start kdump service,

+ grep -q ostree /proc/cmdline
+ '[' / '!=' / ']'
+ '[' -n '' ']'
+ dracut --hostonly --hostonly-cmdline --hostonly-i18n -o 'plymouth dash resume ifcfg' -f /boot/initramfs-3.10.0-691.el7.x86_64kdump.img 3.10.0-691.el7.x86_64
iscsiadm: No records found
Unable to find iscsi record for /sys/devices/pci0000:00/0000:00:06.0/0000:07:00.4/host4/session1
iscsiadm: No records found
Unable to find iscsi record for /sys/devices/pci0000:00/0000:00:06.0/0000:07:00.5/host5/session2
iscsiadm: No records found
Unable to find iscsi record for /sys/devices/pci0000:00/0000:00:06.0/0000:07:00.4/host4/session1
iscsiadm: No records found
Unable to find iscsi record for /sys/devices/pci0000:00/0000:00:06.0/0000:07:00.5/host5/session2
iscsiadm: No records found
Unable to find iscsi record for /sys/devices/pci0000:00/0000:00:06.0/0000:07:00.4/host4/session1
iscsiadm: No records found
Unable to find iscsi record for /sys/devices/pci0000:00/0000:00:06.0/0000:07:00.5/host5/session2
iscsiadm: No records found
Unable to find iscsi record for /sys/devices/pci0000:00/0000:00:06.0/0000:07:00.4/host4/session1
iscsiadm: No records found
Unable to find iscsi record for /sys/devices/pci0000:00/0000:00:06.0/0000:07:00.5/host5/session2
iscsiadm: No records found
Unable to find iscsi record for /sys/devices/pci0000:00/0000:00:06.0/0000:07:00.4/host4/session1
iscsiadm: No records found
Unable to find iscsi record for /sys/devices/pci0000:00/0000:00:06.0/0000:07:00.5/host5/session2
iscsiadm: No records found
Unable to find iscsi record for /sys/devices/pci0000:00/0000:00:06.0/0000:07:00.4/host4/session1
iscsiadm: No records found
Unable to find iscsi record for /sys/devices/pci0000:00/0000:00:06.0/0000:07:00.5/host5/session2
iscsiadm: No records found
Unable to find iscsi record for /sys/devices/pci0000:00/0000:00:06.0/0000:07:00.4/host4/session1
iscsiadm: No records found
Unable to find iscsi record for /sys/devices/pci0000:00/0000:00:06.0/0000:07:00.5/host5/session2
+ _rc=0
+ sync

Other info:
# cat /proc/cmdline 
BOOT_IMAGE=/vmlinuz-3.10.0-691.el7.x86_64 root=/dev/mapper/rhel_storageqe--81-root ro modprobe.blacklist=qla3xxx crashkernel=auto rd.lvm.lv=rhel_storageqe-81/root rd.lvm.lv=rhel_storageqe-81/swap console=ttyS1,115200 LANG=en_US.UTF-8

# multipath -l
mpatha (360fff19abdd9c5c6753155d351262a2b) dm-0 EQLOGIC ,100E-00         
size=50G features='0' hwhandler='0' wp=rw
|-+- policy='service-time 0' prio=0 status=active
| `- 4:0:0:0 sdd 8:48 active undef unknown
`-+- policy='service-time 0' prio=0 status=enabled
  `- 5:0:0:0 sde 8:64 active undef unknown

# grep -v ^# /etc/kdump.conf | sed '/^$/d'
path /var/crash
core_collector makedumpfile -l --message-level 1 -d 31
default shell

And the dump target is multipath device.
# lsblk 
NAME                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                             8:0    0 232.9G  0 disk  
sdb                             8:16   0 465.8G  0 disk  
sdc                             8:32   0 465.8G  0 disk  
sdd                             8:48   0    50G  0 disk  
└─mpatha                      253:0    0    50G  0 mpath 
  ├─mpatha1                   253:1    0     1G  0 part  /boot
  └─mpatha2                   253:2    0    49G  0 part  
    ├─rhel_storageqe--81-root 253:3    0    44G  0 lvm   /
    └─rhel_storageqe--81-swap 253:4    0     5G  0 lvm   [SWAP]
sde                             8:64   0    50G  0 disk  
└─mpatha                      253:0    0    50G  0 mpath 
  ├─mpatha1                   253:1    0     1G  0 part  /boot
  └─mpatha2                   253:2    0    49G  0 part  
    ├─rhel_storageqe--81-root 253:3    0    44G  0 lvm   /
    └─rhel_storageqe--81-swap 253:4    0     5G  0 lvm   [SWAP]
sr0                            11:0    1  1024M  0 rom 


Version-Release number of selected component (if applicable):
kernel-3.10.0-691.el7
kexec-tools-2.0.14-17.el7
dracut-033-502.el7

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Test machine: storageqe-81.lab.eng.brq.redhat.com
Comment 1 Dave Young 2017-07-19 23:01:43 EDT

*** This bug has been marked as a duplicate of bug 1265046 ***

Note You need to log in before you can comment on or make changes to this bug.