Bug 14673 - Multicas route not added by ifup
Multicas route not added by ifup
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
: 14674 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-07-26 15:07 EDT by Tomasz Kepczynski
Modified: 2014-03-16 22:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-26 19:49:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Kepczynski 2000-07-26 15:07:25 EDT
I created route for multicast with linuxconf which yielded:
any net 224.0.0.0 netmask 240.0.0.0 gw eth0
in /etc/sysconfig/static-routes.
This is the only route in this file. The route is not added
as there is an error in ifup-routes script.
Line 19 in script reads:
  if [ "$dev" = "$device" ]; then
This will  return false as in my case $device
has not been assigned yet. I guess this line should
be:
  if [ "$dev" = "$1" ]; then
Comment 1 Jeff Johnson 2000-07-26 19:49:26 EDT
*** Bug 14674 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2000-08-07 01:21:45 EDT
Fixed in initscripts-5.40-1; thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.