Bug 14674 - Multicast route not added by ifup
Multicast route not added by ifup
Status: CLOSED DUPLICATE of bug 14673
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Depends On:
  Show dependency treegraph
Reported: 2000-07-26 15:07 EDT by Tomasz Kepczynski
Modified: 2014-03-16 22:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-07-26 15:07:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Tomasz Kepczynski 2000-07-26 15:07:34 EDT
I created route for multicast with linuxconf which yielded:
any net netmask gw eth0
in /etc/sysconfig/static-routes.
This is the only route in this file. The route is not added
as there is an error in ifup-routes script.
Line 19 in script reads:
  if [ "$dev" = "$device" ]; then
This will  return false as in my case $device
has not been assigned yet. I guess this line should
  if [ "$dev" = "$1" ]; then
Comment 1 Jeff Johnson 2000-07-26 19:49:27 EDT

*** This bug has been marked as a duplicate of 14673 ***

Note You need to log in before you can comment on or make changes to this bug.