Bug 1467333 - exception when user switches between several reports with timelines
exception when user switches between several reports with timelines
Status: CLOSED DUPLICATE of bug 1475782
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.8.0
Unspecified Unspecified
high Severity high
: GA
: 5.8.2
Assigned To: Dávid Halász
Ievgen Zapolskyi
ui:report:timeline
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-03 08:25 EDT by Ievgen Zapolskyi
Modified: 2017-08-21 03:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-21 03:30:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core
izapolsk: automate_bug-


Attachments (Terms of Use)
exception (8.29 KB, text/plain)
2017-07-03 08:25 EDT, Ievgen Zapolskyi
no flags Details
db dump (6.08 MB, application/x-bzip)
2017-07-03 08:45 EDT, Ievgen Zapolskyi
no flags Details

  None (edit)
Description Ievgen Zapolskyi 2017-07-03 08:25:45 EDT
Created attachment 1293882 [details]
exception

Description of problem:
I have 4 default timelines reports and 4 custom ones. Custom reports were made from default ones by slightly updating their filters to show this week events.
When I open reports one by one I get error page and exception in production.log.
I encounter the exception on almost each of those default or custom reports.

Version-Release number of selected component (if applicable):
5.8.1

How reproducible:
100%

Steps to Reproduce:
1. Add f.e. any vsphere provider to cfme
2. Collect events for some time (my db dump is attached) 
3. Go to Cloud Intel->Timelines page and remember default timelines reports
4. Go to Cloud Intel->Reports, find those reports and make their copies
5. Edit every custom report to display "This Week" events
6. Go back to Cloud Intel->Timelines
7. Run through default and custom reports one by one there

Actual results:
Error page and exception in logs
Comment 2 Ievgen Zapolskyi 2017-07-03 08:45 EDT
Created attachment 1293883 [details]
db dump
Comment 4 Ievgen Zapolskyi 2017-07-07 16:29:31 EDT
David, I made db dump using pg_dump. So, you have to import it using postgre tools as well.
btw, I successfully imported it before attaching it to BZ. One note you have to drop old vmdb_production before import because I forgot to specify "cleanup db" when I was dumping that db.
Comment 9 Ievgen Zapolskyi 2017-08-21 03:30:20 EDT
sure, I'll verify it along with 1475782. thank you

*** This bug has been marked as a duplicate of bug 1475782 ***

Note You need to log in before you can comment on or make changes to this bug.