This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1467553 - [WALA] Remove FIPS from default config in WALA-2.2.14
[WALA] Remove FIPS from default config in WALA-2.2.14
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: WALinuxAgent (Show other bugs)
7.4
x86_64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Vitaly Kuznetsov
Virtualization Bugs
: Extras
Depends On:
Blocks: 1451172
  Show dependency treegraph
 
Reported: 2017-07-04 04:00 EDT by yuxisun@redhat.com
Modified: 2017-07-13 09:46 EDT (History)
14 users (show)

See Also:
Fixed In Version: WALinuxAgent-2.2.14-1.el7
Doc Type: If docs needed, set a value
Doc Text:
The upstream FIPS feature is currently not working properly, and is therefore not a part of this update. Note that the functional FIPS feature will be a part of the future update.
Story Points: ---
Clone Of:
: 1467559 (view as bug list)
Environment:
Last Closed: 2017-07-13 09:46:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yuxisun@redhat.com 2017-07-04 04:00:10 EDT
Description of problem:
MSFT wishes us to ship the WALA-2.2.14. But currently the FIPS feature in WALA cannot work well (BZ#1460671).
So shell we remove the FIPS configuration from the waagent.conf and then ship this package?

The FIPS configurations in waagent.conf are:
# Is FIPS enabled
OS.EnableFIPS=n
Comment 2 Miroslav Rezanina 2017-07-04 05:50:57 EDT
Fix included in WALinuxAgent-2.2.14-1.el7
Comment 4 yuxisun@redhat.com 2017-07-05 06:18:43 EDT
Verify in WALinuxAgent-2.2.14-1.el7. Result: PASS
Steps:
1. Prepare a RHEL-7.4 VM in Azure
2. Install the WALinuxAgent-2.2.14-1.el7
3. Check /etc/waagent.conf
Actual result:
There's no line with "FIPS" string.
Comment 6 errata-xmlrpc 2017-07-13 09:46:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1749

Note You need to log in before you can comment on or make changes to this bug.