Bug 1467569 - in the self service portal after a little time displaying a vm, data changes to garbage data
in the self service portal after a little time displaying a vm, data changes ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - Service (Show other bugs)
5.8.0
All All
high Severity high
: GA
: 5.9.0
Assigned To: Chris Hale
Shveta
ssui
: TestOnly, ZStream
Depends On:
Blocks: 1470774
  Show dependency treegraph
 
Reported: 2017-07-04 04:44 EDT by Felix Dewaleyne
Modified: 2018-03-06 09:47 EST (History)
7 users (show)

See Also:
Fixed In Version: 5.9.0.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1470774 (view as bug list)
Environment:
Last Closed: 2018-03-06 09:47:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console (199.80 KB, image/png)
2017-07-11 14:11 EDT, Shveta
no flags Details

  None (edit)
Description Felix Dewaleyne 2017-07-04 04:44:44 EDT
Description of problem:
in the self service portal after a little time displaying a service, data changes to garbage data

Version-Release number of selected component (if applicable):
5.8.0.17

How reproducible:
all the time (customer environment)

Steps to Reproduce:
1.provision service from self-service ui
2.display the details of the service and remain on the page
3.

Actual results:
after a short time displaying the same page the data changes to all fields showing
{{vm.detailTitle}} {{vm.detail}}

Expected results:
the data remains properly shown

Additional info:
Firefox 53 and Chrome 58 were used
sample url affected : https://sample.example.com/ui/service/vms/666000000000234
Comment 3 Felix Dewaleyne 2017-07-05 04:26:05 EDT
closing the page and opening it again displays the proper data until it gets automatically refreshed.
Comment 4 Chris Kacerguis 2017-07-05 11:56:52 EDT
@Felix - Could you get us a copy of the evm logs during one of the events?  Also, in your video, can you do another one with the Javascript console open?
Comment 5 Chris Hale 2017-07-05 14:06:16 EDT
Second Chris's comment above.  I tried to reproduce this locally and was unable to reproduce it.  I think we need to see the javascript console so we can see what is going on behind the scenes.
Comment 6 Chris Kacerguis 2017-07-06 13:16:07 EDT
@Felix - Could you get us a copy of the evm logs during one of the events?  Also, in your video, can you do another one with the Javascript console open?
Comment 7 Chris Kacerguis 2017-07-06 16:39:49 EDT
A Pivotal Tracker story has been created for this Bug: https://www.pivotaltracker.com/story/show/148444919
Comment 10 Shveta 2017-07-11 14:10:09 EDT
I was able to recreate this bug.
Please check https://10.8.197.236/ui/service .
This happens only with stack service VMs.
Service name -> stack_service
Comment 11 Shveta 2017-07-11 14:11 EDT
Created attachment 1296393 [details]
console
Comment 13 Chris Kacerguis 2017-07-11 21:32:28 EDT
*** Bug 1469798 has been marked as a duplicate of this bug. ***
Comment 14 Chris Hale 2017-07-12 13:20:26 EDT
F
Comment 15 Chris Hale 2017-07-12 13:22:21 EDT
Chris.  I was able to see the issue that you are reporting but in working with Shveta, we were able to point me to a appliance that is running Fine and was able to reproduce the issue reported in this ticket.  I have fixed the bug on our side in GH PR https://github.com/ManageIQ/manageiq-ui-service/pull/842.  I recommend we open a separate ticket for the API issue as that is still a valid issue with master.
Comment 16 Chris Kacerguis 2017-07-12 13:24:12 EDT
Chris Hale added a comment in Pivotal Tracker:   
   
Commit by Chris Hale
https://github.com/ManageIQ/manageiq-ui-service/commit/3a4d45c7d7c8b203c3da02650e755a15bd845e57

[Fixes #148444919] Fixes detail-reveal component failing to update
Comment 19 Shveta 2017-10-18 15:32:29 EDT
Fixed in 5.9.0.2.20171010190026_0413a06

Note You need to log in before you can comment on or make changes to this bug.