Bug 1467664 - RHEV compute resource submission fails on name has already been taken error correction
Summary: RHEV compute resource submission fails on name has already been taken error c...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Compute Resources - RHEV
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: orabin
QA Contact: Nikhil Kathole
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-04 13:36 UTC by Nikhil Kathole
Modified: 2019-09-26 15:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-21 16:51:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot of error (24.50 KB, image/png)
2017-07-04 13:36 UTC, Nikhil Kathole
no flags Details
log in production.log file (17.53 KB, text/plain)
2017-07-04 13:57 UTC, Nikhil Kathole
no flags Details
log in production.log file after name already taken (12.55 KB, text/plain)
2017-09-17 09:07 UTC, Nikhil Kathole
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 20452 0 None None None 2017-07-31 09:29:19 UTC

Internal Links: 1481991

Description Nikhil Kathole 2017-07-04 13:36:31 UTC
Created attachment 1294214 [details]
screenshot of error

Description of problem: We are trying to create compute resource with provider RHEV.But at first, we entered name of compute resource which is already exists, so later tried by changing the name of compute resource and found the error as "something went wrong 401 unauthorized".


Version-Release number of selected component (if applicable): 6.3.0


How reproducible: always

Steps to Reproduce:
1. Navigate to infrastructure >> compute resource
2. Create compute resource with some name with any provider.ex:"compute1"
3. Try to create again compute resource but with existing compute resource name with provider "RHEV".
4. It will say "Name has already benn taken"
5. Now change the name of compute resource to any name and click submit


Actual results:
It will show error as "Something went wrong 401 unauthorized" 

Expected results:
Compute resource should be created.


Additional info:

Comment 1 Nikhil Kathole 2017-07-04 13:57:53 UTC
Created attachment 1294228 [details]
log in production.log file

Comment 2 Nikhil Kathole 2017-07-04 14:03:34 UTC
while performing above steps, open production.log file using command:
tail -f /var/log/foreman/production.log

We can see 500 internal error as in attachment.

Comment 4 orabin 2017-07-31 09:29:17 UTC
Created redmine issue http://projects.theforeman.org/issues/20452 from this bug

Comment 5 Satellite Program 2017-07-31 10:06:26 UTC
Upstream bug assigned to orabin

Comment 6 Satellite Program 2017-07-31 10:06:29 UTC
Upstream bug assigned to orabin

Comment 7 Satellite Program 2017-08-07 14:06:28 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/20452 has been resolved.

Comment 8 Nikhil Kathole 2017-09-17 09:06:55 UTC
VERIFIED

Version Tested:
Satellite-6.3 Snap 16

steps:
1. Created compute resource with name 'rhev'
2. Tried to create RHEV compute resource with name 'rhev'
3. Error as name has already taken
4. Change name as 'rhev1' and click save.

Successfully saved compute resource after name change.(see attachment for logs)

Comment 9 Nikhil Kathole 2017-09-17 09:07:48 UTC
Created attachment 1326919 [details]
log in production.log file after name already taken

Comment 10 Satellite Program 2018-02-21 16:51:07 UTC
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA.
> 
> For information on the advisory, and where to find the updated files, follow the link below.
> 
> If the solution does not work for you, open a new bug report.
> 
> https://access.redhat.com/errata/RHSA-2018:0336


Note You need to log in before you can comment on or make changes to this bug.