Bug 1467710 - bind libs changed and buildinstall everything image create is failing in rawhide
bind libs changed and buildinstall everything image create is failing in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Zhukov
Fedora Extras Quality Assurance
:
Depends On: 1468476
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 13:43 EDT by Kevin Fenzi
Modified: 2017-07-07 07:16 EDT (History)
7 users (show)

See Also:
Fixed In Version: dhcp-4.3.5-10.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-07 07:16:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2017-07-04 13:43:16 EDT
https://koji.fedoraproject.org/koji/taskinfo?taskID=20319384

2017-07-04 07:58:03,973: verifying the installroot
verifying the installroot
2017-07-04 07:58:07,161: libirs-export.so.91, needed by /usr/sbin/dhclient, not found
libirs-export.so.91, needed by /usr/sbin/dhclient, not found
2017-07-04 07:58:07,161: libdns-export.so.173, needed by /usr/sbin/dhclient, not found
libdns-export.so.173, needed by /usr/sbin/dhclient, not found
2017-07-04 07:58:07,161: libisccfg-export.so.94, needed by /usr/sbin/dhclient, not found
libisccfg-export.so.94, needed by /usr/sbin/dhclient, not found
2017-07-04 07:58:07,161: libisc-export.so.108, needed by /usr/sbin/dhclient, not found
libisc-export.so.108, needed by /usr/sbin/dhclient, not found

bind just updated so it could be just a version change in what libs are cleaned up?
Comment 1 Kevin Fenzi 2017-07-06 11:36:44 EDT
I have untagged dnsperf-2.1.0.0-7.fc27 and bind-9.11.1-2.P2.fc27 for now so we can get rawhide composes. 

Adding their maintainers here for a heads up.
Comment 2 Kevin Fenzi 2017-07-06 11:55:43 EDT
ok. Looking more it's unclear if thats the problem. 

The issue seems to be up until 2017-07-02, bind99-libs were pulled in, after that they were not. dhclient needs them to work. 

But it's not clear to me what is causing them to not be pulled in... 
There was no dnf change in that time.
Comment 3 Igor Gnatenko 2017-07-07 07:16:19 EDT
commit 8e64716dfb0f7d1fbd70b0ef16295b5c6546d180
Author: Igor Gnatenko <ignatenko@redhat.com>
Date:   Fri Jul 7 13:15:00 2017 +0200

    Rebuild due to bug in RPM (RHBZ #1468476)
    
    Signed-off-by: Igor Gnatenko <ignatenko@redhat.com>

Note You need to log in before you can comment on or make changes to this bug.