Bug 1468476 - When using %filter_setup no automatic dependencies for libraries are generated
When using %filter_setup no automatic dependencies for libraries are generated
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Igor Gnatenko
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1467710 1468993
  Show dependency treegraph
 
Reported: 2017-07-07 04:16 EDT by Igor Gnatenko
Modified: 2017-07-10 05:03 EDT (History)
5 users (show)

See Also:
Fixed In Version: rpm-4.13.0.1-30.fc27
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-07 05:42:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Igor Gnatenko 2017-07-07 04:16:42 EDT
Since 0044-Use-RPMTAG_-NAME-instead-of-RPMTAG_-FLAGS-in-parsePr.patch patch has been applied, dhcp/samba/multiple other packages started to be broken because none of dependencies on libc.so just stopped generating.
Comment 1 Igor Gnatenko 2017-07-07 04:17:16 EDT
I'm trying to debug it.
Comment 2 Igor Gnatenko 2017-07-07 05:42:02 EDT
commit 3992a6874b75ce8ae06dbd74f67331dbb7bd6e56
Author: Igor Gnatenko <ignatenkobrain@fedoraproject.org>
Date:   Fri Jul 7 11:39:07 2017 +0200

    Fix brokeness when using %filter_setup (RHBZ #1468476)
    
    Signed-off-by: Igor Gnatenko <ignatenkobrain@fedoraproject.org>

Note You need to log in before you can comment on or make changes to this bug.