Bug 1467715 - Include director UI logs in sosreport
Include director UI logs in sosreport
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sos (Show other bugs)
7.4
Unspecified Unspecified
medium Severity medium
: pre-dev-freeze
: 7.5
Assigned To: Pavel Moravec
BaseOS QE - Apps
:
Depends On: 1468053 1470573
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-04 14:43 EDT by Honza Pokorny
Modified: 2018-04-11 02:52 EDT (History)
14 users (show)

See Also:
Fixed In Version: sos-3.5-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-11 02:52:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Honza Pokorny 2017-07-04 14:43:29 EDT
Find a way to include the director UI logs in the sosreport to encourage OSPD UI adoption.
Comment 1 Honza Pokorny 2017-10-06 09:56:48 EDT
All code changes that were done are referenced in 1468053
Comment 5 Udi 2017-11-20 05:15:14 EST
Hi Honza. How do I find the UI's logs in all the files in the sosreport? Is it the zaqar log in var/log/zaqar ?
Comment 6 Honza Pokorny 2017-11-20 09:59:18 EST
The tripleo-ui log file should be here: 

sos_commands/openstack_instack/openstack_object_save_tripleo-ui-logs_tripleo-ui.logs_--file

If not, then check that OS_TENANT_NAME is properly exported in /home/stack/stackrc.
Comment 7 Udi 2017-11-20 11:52:20 EST
This is suffering from the same bug we have in: https://bugzilla.redhat.com/show_bug.cgi?id=1513453. Only 10 actions are logged... Should we mark this bug as blocked?
Comment 23 Jon Schlueter 2018-01-31 15:43:19 EST
sos-3.4-13.el7_4 - is currently available in RHEL 7.4 - zstream and from prior discussions I think this should cover this RFE but would need to test to see if that is the case yet.
Comment 24 Pavel Moravec 2018-02-05 08:36:20 EST
Please what in particular is required to collect?

What log file(s) in particular? What shall trigger collecting them (i.e. what package or file presence)?

pls. check against sos-3.5-4 package


(also re-scheduling to 7.6 as scope of 7.5 is quite closed)
Comment 25 Pavel Moravec 2018-03-03 11:59:08 EST
(In reply to Pavel Moravec from comment #24)
> Please what in particular is required to collect?
> 
> What log file(s) in particular? What shall trigger collecting them (i.e.
> what package or file presence)?
> 
> pls. check against sos-3.5-4 package
> 
> 
> (also re-scheduling to 7.6 as scope of 7.5 is quite closed)

Hello,
could you pls. answer this needinfo?
Comment 29 Pavel Moravec 2018-04-11 02:52:06 EDT
This BZ shall be fixed in RHEL7.5 via errata

https://access.redhat.com/errata/RHEA-2018:0963

The codefix appears there due to sos rebase to 3.5.

Note You need to log in before you can comment on or make changes to this bug.