Bug 1467781 - Can't import an existing block storage domain with Discard After Delete checked
Can't import an existing block storage domain with Discard After Delete checked
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
4.2.0
Unspecified Unspecified
unspecified Severity high (vote)
: ovirt-4.2.0
: ---
Assigned To: Idan Shaby
Elad
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 02:55 EDT by Idan Shaby
Modified: 2017-12-20 06:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:46:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
rule-engine: blocker+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79016 master MERGED backend: DAD initialization in AddExistingBlockStorageDomain 2017-07-06 03:16 EDT

  None (edit)
Description Idan Shaby 2017-07-05 02:55:23 EDT
Description of problem:
Since bug 1456414 was implemented, it's not possible to import an existing block storage domain using the UI with its default values (DAD = true).

Version-Release number of selected component (if applicable):
ab5097fde94fb96318e8b767ecd39e31d07d1700

How reproducible:
100%

Steps to Reproduce:
1. Import an existing block storage domain using the UI.
2. Don't change the DAD value (should be checked).

Actual results:
Fails with the error "Discard after delete is supported only by block domains".

Expected results:
Should work
Comment 1 Red Hat Bugzilla Rules Engine 2017-07-05 03:02:03 EDT
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.
Comment 2 Elad 2017-07-19 03:58:19 EDT
Block based storage domain import succeeded without changing the discard after delete value (the default is true).

Tested via Webadmin using:
ovirt-engine-4.2.0-0.0.master.20170717104433.gita1ba045.el7.centos.noarch
vdsm-4.20.1-202.git9f953f3.el7.centos.x86_64
Comment 3 Sandro Bonazzola 2017-12-20 06:46:18 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.