Bug 1467809 - overlay docker storage driver should be supported for old operation systems in health check
overlay docker storage driver should be supported for old operation systems i...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rodolfo Carvalho
Gan Huang
:
Depends On:
Blocks: 1469197
  Show dependency treegraph
 
Reported: 2017-07-05 04:27 EDT by Gan Huang
Modified: 2017-08-16 15 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1469197 (view as bug list)
Environment:
Last Closed: 2017-07-17 10:00:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gan Huang 2017-07-05 04:27:07 EDT
Description of problem:
Trigger a installation on RHEL7.2/RHEL7.3 with overlay driver enabled, it failed at openshift_health_check:
       
 "docker_storage": {
            "changed": true, 
            "failed": true, 
            "msg": "Detected unsupported Docker storage driver 'overlay'.\nSupported storage drivers are: devicemapper, overlay2"

Version-Release number of selected component (if applicable):
openshift-ansible-3.6.133-1.git.0.950bb48.el7.noarch.rpm

How reproducible:
always

Steps to Reproduce:
1. Provision RHEL 7.2/7.3 to be installed, and enabled overlay docker storage driver.
2. Trigger 3.6 installation
#cat inventory_hosts
<--snip-->
openshift_docker_selinux_enabled=false
<--snip-->

Actual results:
Installation failed at health check:
 "docker_storage": {
            "changed": true, 
            "failed": true, 
            "msg": "Detected unsupported Docker storage driver 'overlay'.\nSupported storage drivers are: devicemapper, overlay2"


Expected results:
For old operation system, we should be able to tolerate overlay docker storage by detecting kernel version.


Additional info:
Comment 2 Luke Meyer 2017-07-05 09:15:46 EDT
I don't believe overlay has ever been a driver we support for Docker, nor that it ever will be (given support coming for overlay2). I thought it was only tech preview. Do you know otherwise? Customers may be using it but that doesn't mean we support it.
Comment 5 Luke Meyer 2017-07-06 09:35:35 EDT
This is a legitimate bug, overlay and overlay2 drivers are considered supported for the Docker use case since RHEL 7.3.(4? 5?) under limited conditions. With 7.4 they will actually work under --selinux-enabled too, but before that should have it disabled. Need to figure out corresponding kernel versions and consider what to say for non-RHEL/CentOS.
Comment 6 Rodolfo Carvalho 2017-07-10 11:50:26 EDT
Adding overlay to the list of supported drivers in https://github.com/openshift/openshift-ansible/pull/4722

Later on we may refine the check to verify other conditions as Luke mentions.
Comment 7 Luke Meyer 2017-07-12 09:01:47 EDT
PR merged to master. This is just the simplest fix that allows you to use "overlay" without really checking anything else if you are.
Comment 8 Rodolfo Carvalho 2017-07-14 10:24:39 EDT
Gan Huang, could you re-test please?
Comment 9 Gan Huang 2017-07-17 02:59:10 EDT
Verified in openshift-ansible-3.6.151-1.git.0.a82f0c2.el7.noarch.rpm
Comment 10 Luke Meyer 2017-07-17 10:00:15 EDT
Closing as never released.

Note You need to log in before you can comment on or make changes to this bug.