Bug 1469197 - overlay docker storage driver should be supported for old operation systems in health check
overlay docker storage driver should be supported for old operation systems i...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Luke Meyer
Gan Huang
:
Depends On: 1467809
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-10 12:04 EDT by Luke Meyer
Modified: 2017-08-16 15 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of: 1467809
Environment:
Last Closed: 2017-08-10 01:31:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Luke Meyer 2017-07-10 12:06:42 EDT
Cloning this bug to track refining the check such that it checks the conditions under which overlay/overlay2 are supported.
Comment 3 openshift-github-bot 2017-07-20 08:47:25 EDT
Commit pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/2b1c7492c3c8400370bf675c93cc9ba4b4f83427
openshift_checks/docker_storage: overlay/2 support

fix bug 1469197
https://bugzilla.redhat.com/show_bug.cgi?id=1469197

When Docker is configured with the overlay or overlay2 storage driver,
check that it is supported and usage is below threshold.
Comment 4 Luke Meyer 2017-07-20 10:19:54 EDT
Should be able to get https://github.com/openshift/openshift-ansible/pull/4791 merged for the 3.6.0 release so this should be unreleased.
Comment 5 Luke Meyer 2017-07-20 11:36:42 EDT
Merged to the 3.6 branch.

The implementation now checks that overlay/overlay2 storage is backed by xfs, that it has sufficient storage (configurable via max_overlay_usage_percent), and that the kernel is RHEL 7.3 or later (on EL systems).

It is also possible now to use the overlay drivers and not have ansible reconfigure docker to add --selinux-enabled (Docker refuses to start if these are combined) by specifying openshift_docker_selinux_enabled=False.
Comment 7 Gan Huang 2017-07-24 05:26:12 EDT
Verified with openshift-ansible-3.6.167-1.git.0.0ce5583.el7.noarch.rpm
Comment 9 errata-xmlrpc 2017-08-10 01:31:01 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1716

Note You need to log in before you can comment on or make changes to this bug.