Bug 1467855 - openssl debuginfo conflicts
openssl debuginfo conflicts
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: compat-openssl10 (Show other bugs)
26
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mraz
Fedora Extras Quality Assurance
:
: 1469165 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-05 06:46 EDT by Jerry Amundson
Modified: 2017-09-04 12:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-04 12:03:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerry Amundson 2017-07-05 06:46:57 EDT
Description of problem:
Error: Transaction check error:
  file /usr/lib/debug/usr/lib64/libcrypto.so.debug from install of compat-openssl10-debuginfo-1:1.0.2j-6.fc26.x86_64 conflicts with file from package openssl-debuginfo-1:1.1.0f-4.fc26.x86_64
  file /usr/lib/debug/usr/lib64/libssl.so.debug from install of compat-openssl10-debuginfo-1:1.0.2j-6.fc26.x86_64 conflicts with file from package openssl-debuginfo-1:1.1.0f-4.fc26.x86_64


Version-Release number of selected component (if applicable):
compat-openssl10-1.0.2j-6.fc26.x86_64

How reproducible:
Twice

Steps to Reproduce:
1. sudo dnf -y debuginfo-install compat-openssl10-1.0.2j-6.fc26.x86_64 dbusmenu-qt5-0.9.3-0.12.20150604.fc26.x86_64 gamin-0.1.10-25.fc26.x86_64 kf5-frameworkintegration-libs-5.35.0-1.fc26.x86_64 kf5-karchive-5.35.0-1.fc26.x86_64 kf5-kauth-5.35.0-1.fc26.x86_64 kf5-kcodecs-5.35.0-1.fc26.x86_64 kf5-kconfig-core-5.35.0-1.fc26.x86_64 kf5-kconfig-gui-5.35.0-1.fc26.x86_64 kf5-kconfigwidgets-5.35.0-1.fc26.x86_64 kf5-kcoreaddons-5.35.0-1.fc26.x86_64 kf5-kguiaddons-5.35.0-1.fc26.x86_64 kf5-ki18n-5.35.0-1.fc26.x86_64 kf5-kiconthemes-5.35.0-1.fc26.x86_64 kf5-kitemviews-5.35.0-1.fc26.x86_64 kf5-kwayland-5.35.0-1.fc26.x86_64 kf5-kwidgetsaddons-5.35.0-1.fc26.x86_64 kf5-kwindowsystem-5.35.0-1.fc26.x86_64 libICE-1.0.9-9.fc26.x86_64 libSM-1.2.2-5.fc26.x86_64 libXxf86vm-1.1.4-4.fc26.x86_64 libdrm-2.4.81-1.fc26.x86_64 libevdev-1.5.7-1.fc26.x86_64 libgudev-230-4.fc26.x86_64 libicu-57.1-6.fc26.x86_64 libinput-1.7.3-1.fc26.x86_64 libmodman-2.0.1-13.fc26.x86_64 libproxy-0.4.15-1.fc26.x86_64 libqtxdg-2.0.0-3.fc26.x86_64 libwacom-0.25-1.fc26.x86_64 libxshmfence-1.2-4.fc26.x86_64 libyui-mga-qt-1.0.3-0.8.gitb508e88.20140119.fc26.x86_64 libyui-qt-2.47.1-4.fc26.x86_64 llvm-libs-4.0.0-2.fc26.x86_64 lxqt-qtplugin-0.11.1-3.fc26.x86_64 mtdev-1.1.5-7.fc26.x86_64 plasma-breeze-5.10.1-1.fc26.x86_64 qt5-qtbase-5.7.1-15.fc26.x86_64 qt5-qtbase-gui-5.7.1-15.fc26.x86_64 qt5-qtdeclarative-5.7.1-8.fc26.x86_64 qt5-qtsvg-5.7.1-3.fc26.x86_64 qt5-qtx11extras-5.7.1-3.fc26.x86_64 xcb-util-0.4.0-6.fc26.x86_64 xcb-util-image-0.4.0-5.fc26.x86_64 xcb-util-keysyms-0.4.0-4.fc26.x86_64 xcb-util-renderutil-0.3.9-7.fc26.x86_64 xcb-util-wm-0.4.1-9.fc26.x86_64
2.
3.

Actual results:
Error

Expected results:
Installed rpms

Additional info:
Comment 1 Jerry Amundson 2017-07-07 08:15:06 EDT
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/lib/debug/usr/lib64/libcrypto.so.debug from install of compat-openssl10-debuginfo-1:1.0.2j-6.fc26.x86_64 conflicts with file from package openssl-debuginfo-1:1.1.0f-4.fc26.x86_64
  file /usr/lib/debug/usr/lib64/libssl.so.debug from install of compat-openssl10-debuginfo-1:1.0.2j-6.fc26.x86_64 conflicts with file from package openssl-debuginfo-1:1.1.0f-4.fc26.x86_64

Error Summary
-------------

[jamundson@snoopygoat ~]$ rpm -qf /usr/lib/debug/usr/lib64/libcrypto.so.debug /usr/lib/debug/usr/lib64/libssl.so.debug
openssl-debuginfo-1.1.0f-4.fc26.x86_64
openssl-debuginfo-1.1.0f-4.fc26.x86_64
Comment 2 Tomas Mraz 2017-07-10 09:57:51 EDT
Unfortunately this is inevitable. I am not sure if it would be somehow possible to exclude the /usr/lib/debug/usr/lib64/libcrypto.so.debug and /usr/lib/debug/usr/lib64/libssl.so.debug files from the debuginfo as the debuginfo packages are autogenerated.
Comment 3 Tomas Mraz 2017-07-10 11:08:36 EDT
*** Bug 1469165 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.