Bug 1467858 - [v2v] rephrase "Drivers ISO" label in the v2v dialog
[v2v] rephrase "Drivers ISO" label in the v2v dialog
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.8.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.9.0
Assigned To: Tomas Jelinek
Ilanit Stein
rhev, v2v
: Reopened, TestOnly, ZStream
Depends On:
Blocks: 1480586
  Show dependency treegraph
 
Reported: 2017-07-05 07:04 EDT by Ilanit Stein
Modified: 2018-03-06 10:32 EST (History)
10 users (show)

See Also:
Fixed In Version: 5.9.0.1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1480586 (view as bug list)
Environment:
Last Closed: 2018-03-06 10:32:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: RHEVM


Attachments (Terms of Use)
Drivers ISO (40.14 KB, image/png)
2017-07-05 07:04 EDT, Ilanit Stein
no flags Details

  None (edit)
Description Ilanit Stein 2017-07-05 07:04:31 EDT
Created attachment 1294547 [details]
Drivers ISO

Description of problem:
When marking 'install drivers' check box, a 'Drivers ISO' field is added to the v2v dialog. This added field has a tool tip message: 
"ISO where drivers are located"

It seems that when marking the install drivers check box, a field of Driver should be added, containing the list of all available drivers.

In that case the name 'Drivers ISO' should change into 'Driver',
and tool tip change as well to some other relevant message.

In case the intention here was to list the available ISO domains,
then need to name this added field like 'ISO Domain'.

Version-Release number of selected component (if applicable):
CFME-5.8.1.0/RHV-4.1.3
Comment 2 Martin Betak 2017-07-10 03:53:32 EDT
@Ilanit for such errors in dialogues made through automate (like the v2v dialog happens to be) please always provide the log/automation.log
Comment 3 Ilanit Stein 2017-07-10 04:56:07 EDT
This bug is about:

The name of field: "Drivers ISO".
It should be either "Drivers" or "ISO domains", based on the field purpose.

The tool tip help message, attached to this field, 
"ISO where drivers are located", should of course match this field:

For field name "Drivers", can be: "Drivers found on ISO domain".
For field name "ISO domains", can be: "ISO domains where drivers are located"

So no need for logs, for this bug.
Comment 4 Martin Betak 2017-07-10 05:10:37 EDT
Yes, sorry this comment was intended for bug https://bugzilla.redhat.com/show_bug.cgi?id=1467856 :)
Comment 5 Martin Betak 2017-07-10 05:22:28 EDT
Regarding the intent of the listbox itself, it should reflect the list of ISOs (which themselves contain the appropriate driver(s)) of the ISO domain of the target (selected in the first lisbox) RHV provider.

Please note that for this the domain should be added to the provider and refreshed.
Comment 6 Martin Betak 2017-07-10 05:23:54 EDT
Closing since the text is as intended and the listbox <script> failure is tracked in https://bugzilla.redhat.com/show_bug.cgi?id=1467856
Comment 7 Ilanit Stein 2017-07-18 08:55:52 EDT
Reopen because even if "Drivers ISO" is sort of clear to be referring the ISO images of the drivers,
The help message associated with it is wrong:
"ISO where drivers are located"

It is not ISO datastore where drivers are located, but rather ISO images of the Drivers.
So should be something like:
"Driver's ISO images"
Comment 8 Ilanit Stein 2017-07-18 09:11:43 EDT
Also regarding "Drivers ISO" - maybe it will be more clear if it will be called:
"Driver's ISO"
Comment 9 Tomas Jelinek 2017-08-10 05:42:07 EDT
So, we can change it to:
Label: "Drivers ISO Images"
Empty value: "--- select image from list ---"
Tooltip: "Image where the drivers are located"
Comment 10 Martin Betak 2017-08-10 06:27:30 EDT
maybe we can simplify this to:
Label: "Drivers"
Empty value: "--- select image from list ---"
Tooltip: "Image with drivers"
Comment 13 Tomas Jelinek 2017-08-11 10:20:16 EDT
So, tu summarize what has been actually merged:

checbox:
label: Install Windows Drivers
tooltip: Install necessary Windows drivers as a part of the conversion process

empty value: -- select image from list --
label: Install Windows Drivers
Tooltip: Image with drivers

The checkbox will be checked/uncheck according to the source OS once  https://bugzilla.redhat.com/show_bug.cgi?id=1472843 is implemented
Comment 14 Ilanit Stein 2018-01-01 05:32:59 EST
Verified on CFME-5.9.0.14/RHV-4.1.8

Note You need to log in before you can comment on or make changes to this bug.