Bug 1467914 - Neutron support for VNIC_VIRTIO_FORWARDER
Neutron support for VNIC_VIRTIO_FORWARDER
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-neutron-lib (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
low Severity medium
: beta
: 12.0 (Pike)
Assigned To: Ihar Hrachyshka
Toni Freger
: FutureFeature, Triaged
Depends On:
Blocks: 1389435 1467916 1467926 1467918
  Show dependency treegraph
 
Reported: 2017-07-05 09:41 EDT by Jan Gutter
Modified: 2017-12-13 16:37 EST (History)
15 users (show)

See Also:
Fixed In Version: python-neutron-lib-1.9.0-0.20170720214524.7581af4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-13 16:37:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 483530 None None None 2017-07-17 10:04 EDT

  None (edit)
Description Jan Gutter 2017-07-05 09:41:29 EDT
Preface:

The intention of this bug is to provide insight into a feature proposed by Netronome for inclusion in RHOSP12.

Description:

Work is underway to extend the list of supported VNIC types in OpenStack in order to support a lightweight VF-to-vhostuser virtio proxy. This mechanism would allow a VM to boot with a vhostuser interface where the proxy on the hypervisor does not itself to complex switching.

The key difference between standard vhostuser plugs is that VNIC_VIRTIO_FORWARDER will consume a VF resource.

This provides another plugging method into accelerated and offloaded NICs.

Status:

Patches are in internal testing, RFE+patches will be submitted by 07/07 2017 to Neutron.
Comment 1 Ihar Hrachyshka 2017-07-11 10:05:33 EDT
Were patches submitted?
Comment 2 Jan Gutter 2017-07-14 12:46:56 EDT
(In reply to Ihar Hrachyshka from comment #1)
> Were patches submitted?

Apologies, late in the dev cycle it was discovered that a new VIF type would be required. The patches are submitted at:

https://review.openstack.org/#/c/483530/

End-to-end testing with Nova, Neutron, OS-VIF and the external plugins have verified that these changes to core Neutron are sufficient.
Comment 3 Jan Gutter 2017-07-20 06:19:15 EDT
The review was merged and landed in neutron-lib 1.9.0
Comment 6 Ihar Hrachyshka 2017-11-06 16:57:10 EST
Verified that the symbol is shipped with neutron-lib. Note that support for the new vif type is a broader request and is out of scope for this particular bug.
Comment 9 errata-xmlrpc 2017-12-13 16:37:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462

Note You need to log in before you can comment on or make changes to this bug.