Bug 1467918 - Neutronclient support for VNIC_VIRTIO_FORWARDER
Neutronclient support for VNIC_VIRTIO_FORWARDER
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-neutronclient (Show other bugs)
12.0 (Pike)
Unspecified Unspecified
low Severity low
: ---
: 12.0 (Pike)
Assigned To: Ihar Hrachyshka
Toni Freger
: Triaged
Depends On: 1467914
Blocks: 1467926
  Show dependency treegraph
 
Reported: 2017-07-05 09:54 EDT by Jan Gutter
Modified: 2017-07-26 12:26 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-26 12:26:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 483533 None None None 2017-07-17 09:46 EDT

  None (edit)
Description Jan Gutter 2017-07-05 09:54:21 EDT
Preface:

The intention of this bug is to provide insight into a feature proposed by Netronome for inclusion in RHOSP12.

Description:

Work is underway to extend the list of supported VNIC types in OpenStack in order to support a lightweight VF-to-vhostuser virtio proxy. This mechanism would allow a VM to boot with a vhostuser interface where the proxy on the hypervisor does not itself to complex switching.

The key difference between standard vhostuser plugs is that VNIC_VIRTIO_FORWARDER will consume a VF resource.

This provides another plugging method into accelerated and offloaded NICs.

Status:

Patches are in internal testing, RFE+patches will be submitted by 07/07 2017 to Neutron.
Comment 1 Ihar Hrachyshka 2017-07-11 10:04:43 EDT
Were patches submitted?
Comment 2 Jan Gutter 2017-07-14 12:50:52 EDT
(In reply to Ihar Hrachyshka from comment #1)
> Were patches submitted?

Apologies, late in the dev cycle it was discovered that a new VIF type would be required, the changes to python-neutronclient and python-openstackclient remained the same, however. The patches are submitted at:

https://review.openstack.org/#/c/483532
https://review.openstack.org/#/c/483533
Comment 3 Jan Gutter 2017-07-21 05:02:24 EDT
The patches to python-openstackclient were accepted, but since python-neutronclient has been frozen and deprecated since Ocata, it might not be merged there. This does not block support in Horizon, however.
Comment 4 Jan Gutter 2017-07-23 16:41:52 EDT
The change to python-neutronclient was abandoned due to the freeze.
Comment 5 Ihar Hrachyshka 2017-07-26 12:26:48 EDT
Closing the bug as WONTFIX since it does conflict with upstream plans for neutronclient. No major product/integration issues are expected from the upstream decision.

Note You need to log in before you can comment on or make changes to this bug.