Bug 146807 - Norwegian dictionary missing in 1.1.3 package recently pushed
Norwegian dictionary missing in 1.1.3 package recently pushed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
: Regression
: 146767 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-01 14:15 EST by Kyrre Ness Sjøbæk
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.9.85-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 11:01:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kyrre Ness Sjøbæk 2005-02-01 14:15:18 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Every instalation - unless you add the language files yourself

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Could you just please confirm that norwegian-bokmål and
norwegian-nynorsk spelling is removed when you update from 1.1.2 to
1.1.3? I think it did, but can't explain it, as it didn't happen after
a "install missing dict -> rollback to 1.1.2 -> re-update-to 1.1.3 ->
its still there" session.

And it's pretty urgent, as i se on the test-list that you propose to
push a new 1.1.3 package pretty soon - something which *normaly*
aren't done to often due to their huge size...
Comment 1 Dan Williams 2005-02-01 15:23:40 EST
Here's the problem...  a number of dictionaries were removed to fix
the problem of "right-click freezes entire machine and crashes OOo...".
Comment 2 Kyrre Ness Sjøbæk 2005-02-01 17:46:59 EST
ahh... The bug i personaly bitched about several times on the mailing
lists :)

I thought you would just implement the "cat dictionaries.lst | sort |
uniq" thing...

Just wonder - where are the "installed languages" stored? Would it be
possible to include a script in the rpm's %post section, that would
create a dictionaries.lst with *only* those languages + 2 or 3
"basics" (say, english US/brittish)? That wold mean:
- all people get happy, have their own language
- no "crash"

And ofcource, all of this is going to be properly fixed by the release
of fc4 anyway, so why not do this? Yes, it is a bit dirty etc - but it
will work, people will be happy etc.
Comment 3 Dan Williams 2005-02-01 20:48:03 EST
Well, unfortunately more than about 6 or 8 dictionaries seems to be bad :(
Comment 4 Kyrre Ness Sjøbæk 2005-02-02 11:41:12 EST
But how many *do* have more than 4 or 6 languages installed? I mean
*really*? Okay, there are those "everything" instalations. To bad for
them?

Come on. Lets make it as good as possible, even if we can't get it all.
Comment 5 Dan Williams 2005-02-02 12:10:39 EST
No, but the point is this:  when you install the dictionary to
/usr/lib/ooo-1.1/share/dict/ooo _and_ you add it to dictionary.lst,
OOo will load the dictionary into memory when you right-click.

You _cannot_ escape this behavior _and_ have the dictionaries show up
by default.  If we didn't add them to dictionary.lst, then people
would have to edit dictionary.lst themselves to add the dictionary,
which is sub-optimal and doesn't work out of the box.  So you either
add the things to dictionary.lst and suffer the consequences of
freeze-on-right-click, or you don't add them and you make people edit
the text file themselves.

That said, we should probably install the dictionaries, but not add
them to dictionary.lst.  But, we'll get people who will say "my
dictionary isn't here!" because it doesn't show up in the
Tools->Options->Language Options, because its not in dictionary.lst...
Comment 6 Kyrre Ness Sjøbæk 2005-02-02 12:41:32 EST
What i meant is *almost* what you mean. Install all the dictionaries,
and use a script during instalation to edit the dictionary.lst so that
it *only* contains installed languages. Those that shows up in
system-config-language, maybe plus english.

Or at least just comment out the "missing" dictionaries?

Please?
Comment 7 Dan Williams 2005-02-22 10:02:38 EST
*** Bug 146767 has been marked as a duplicate of this bug. ***
Comment 8 Mephisto 2005-02-22 11:00:06 EST
so how about adding no dictonaries at all to a default OOo install, and creating
seperate packages for all other languages? this is how its done in aspell.
i dont know if its possible though, since OOo uses this 'list-file' method
(which is pretty bad imho, because it requires the user to edit config files to
make things work), but maybe a script can take care of this?
Comment 9 Dan Williams 2005-02-22 11:10:20 EST
Comment 8: dictionaries will be split out individually for FC4.
Comment 10 Caolan McNamara 2005-03-21 11:01:02 EST
I've split the dictionaries out into the langpacks for FC4 and modified the
myspell thing to see if a dictionary listed in the dictionary.lst is really
there at startup. So installing your langpack will install your dictionary if
the language has an available dictionary.

Note You need to log in before you can comment on or make changes to this bug.