Bug 1468191 - Enable stat-prefetch in group virt
Enable stat-prefetch in group virt
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krutika Dhananjay
: Triaged
Depends On:
Blocks: 1468484
  Show dependency treegraph
 
Reported: 2017-07-06 05:18 EDT by Krutika Dhananjay
Modified: 2017-09-05 13:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.12.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-09-05 13:36:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krutika Dhananjay 2017-07-06 05:18:15 EDT
Description of problem:

We saw improvement in IOPs as part of performance improvement effort for gluster with vm store use case. As per volume profile data collected, qemu sends almost as many stats as the number of reads in pure random read workload. With stat-prefetch on, the number of stats hitting the disk got reduced to < 100.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Worker Ant 2017-07-06 05:24:20 EDT
REVIEW: https://review.gluster.org/17713 (extras: Enable stat-prefetch in virt profile) posted (#1) for review on master by Krutika Dhananjay (kdhananj@redhat.com)
Comment 2 Worker Ant 2017-07-10 03:53:39 EDT
COMMIT: https://review.gluster.org/17713 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit f28b5d1007644749761fd374d951b72ace2e203e
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Thu Jul 6 14:25:09 2017 +0530

    extras: Enable stat-prefetch in virt profile
    
    In the internal testing that was done, stat-prefetch did help
    reduce the number of stats coming from qemu hitting the disk,
    and thereby improved performance.
    
    Change-Id: Icf1ce62ecf4e96b97e1946a77b30434157a7786a
    BUG: 1468191
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: https://review.gluster.org/17713
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 3 Shyamsundar 2017-09-05 13:36:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.12.0, please open a new bug report.

glusterfs-3.12.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-September/000082.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.