Bug 1468484 - Enable stat-prefetch in virt profile
Summary: Enable stat-prefetch in virt profile
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: core
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHGS 3.3.0
Assignee: Krutika Dhananjay
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On: 1468191
Blocks: Gluster-HC-3 1417151 RHHI-1.1-Approved-Backlog-BZs
TreeView+ depends on / blocked
 
Reported: 2017-07-07 08:33 UTC by SATHEESARAN
Modified: 2017-09-21 05:02 UTC (History)
10 users (show)

Fixed In Version: glusterfs-3.8.4-34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
RHHI
Last Closed: 2017-09-21 05:02:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2774 normal SHIPPED_LIVE glusterfs bug fix and enhancement update 2017-09-21 08:16:29 UTC

Description SATHEESARAN 2017-07-07 08:33:48 UTC
Description of problem:
-----------------------
'virt' profile available under /var/lib/glusterd/groups/virt when set on the volume optimizes the volume for VM store usecase. This file disables md-cache ( stat-prefetch )

With the latest perf testing, its been found out that with md-cache there is lot of improvement gain, and its concluded that its crucial to have md-cache enabled.

For this to happen, the line that disables stat-prefetch 
'performance.stat-prefetch=off' has to be removed.


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
RHGS 3.2.0 

How reproducible:
-----------------
Not Applicable

Steps to Reproduce:
1.
2.
3.

Actual results:
---------------
stat-prefetch is disabled in virt-profile

Expected results:
-----------------
stat-prefetch needs to be enabled

Additional info:
----------------
We need to remove the line that disables stat-prefetch in virt-profile

Comment 1 SATHEESARAN 2017-07-07 08:35:09 UTC
Missed the steps to reproduce in comment0

Steps to Reproduce:
1. # cat /var/lib/glusterd/groups/virt | grep 'stat-prefetch'

Comment 2 Atin Mukherjee 2017-07-07 08:53:10 UTC
upstream patch : https://review.gluster.org/#/c/17713/

Comment 3 Krutika Dhananjay 2017-07-12 08:36:40 UTC
https://code.engineering.redhat.com/gerrit/#/c/112060/

Comment 9 SATHEESARAN 2017-07-22 11:13:05 UTC
Tested with glusterfs-3.8.4-35.el7rhgs

The content of virt file is:
[root@d ~]# cat /var/lib/glusterd/groups/virt 
performance.quick-read=off
performance.read-ahead=off
performance.io-cache=off
performance.low-prio-threads=32
network.remote-dio=enable
cluster.eager-lock=enable
cluster.quorum-type=auto
cluster.server-quorum-type=server
cluster.data-self-heal-algorithm=full
cluster.locking-scheme=granular
cluster.shd-max-threads=8
cluster.shd-wait-qlength=10000
features.shard=on
user.cifs=off

[root@ ~]# rpm -qf /var/lib/glusterd/groups/virt
glusterfs-server-3.8.4-35.el7rhgs.x86_64

performance.stat-prefetch is not disabled with the virt profile

Comment 11 errata-xmlrpc 2017-09-21 05:02:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2774


Note You need to log in before you can comment on or make changes to this bug.