Bug 1468197 - TYPO3 >= 8.7.3 demands a newer PCRE Version than 8.32
TYPO3 >= 8.7.3 demands a newer PCRE Version than 8.32
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: pcre (Show other bugs)
7.3
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Pisar
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-06 05:39 EDT by Michael Seevogel
Modified: 2017-07-07 09:07 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-07 03:08:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Seevogel 2017-07-06 05:39:18 EDT
Description of problem:
Newer PHP Applications like TYPO3 >= 8.7.3 demand a newer PCRE Version to work.¹
With other words: It's impossible to set up a >= TYPO3 8.7.3 Website on EL7.
The PHP Project also recommends newer PCRE Versions than 8.32 in conjunction with PHP >= 5.5.10 ²

I am aware that EL7 actually only ships with PHP 5.4, so I could understand that updating PCRE is not a priority (or not wanted), but there are alot of EL7 Webservers which do run also newer PHP Versions, like PHP 7 for example from Remi's Repo.


So the questions is: Are there any intentions to raise the PCRE Version for EL7 (perhaps even for EL6?), or are there intentions from EPEL or Remi Repo maintainers to provide newer PCRE Versions?

Currently it's just impossible to install an enterprise CMS like TYPO3 8.7.x on EL7 without to use a self-compiled RPM of PCRE >= 8.38.


Additional info:
[1] https://forge.typo3.org/issues/81335
[2] https://secure.php.net/manual/en/pcre.installation.php
Comment 2 Petr Pisar 2017-07-07 03:08:57 EDT
You can use Red Hat Software Collections <https://www.redhat.com/en/resources/red-hat-software-collections> that provide Red Hat-supported PHP 7.0.10. For more details please contact Red Hat support.
Comment 3 Petr Pisar 2017-07-07 04:33:59 EDT
To answer your question: no, there is no plan to upgrade pcre package in RHEL-7. 

Maybe you could be interested in PCRE2 that is heading to RHEL-7.4. PCRE2 is a new implementation of PCRE and any new piece of software should use that instead of the old PCRE.
Comment 4 Michael Seevogel 2017-07-07 06:04:42 EDT
PCRE2 will replace PCRE in RHEL-7.4?

If yes, then this is a good news, but if not, the problem with the old PCRE Version will still remain.

httpd is using through the configure flag the old PCRE Version.
If I would like to use as of today a newer PCRE Version the only two current options are:

  1. Recompile httpd to use PCRE2
  2. Replace PCRE with a newer and recompiled version from Fedora

Both options are rather bad considering that we are talking about a LTS binary distribution. In short term both of these options might do the job, but again, this could be, if at all, only a temporary solution.

I am pretty sure that this situation will arise more and more also for other customers/users of EL7 so I hope this will lead somehow and on someway to a solution.
Comment 5 Petr Pisar 2017-07-07 09:03:54 EDT
(In reply to Michael Seevogel from comment #4)
> PCRE2 will replace PCRE in RHEL-7.4?
>
No, it won't. They will be both.

Note You need to log in before you can comment on or make changes to this bug.