Bug 1468376 - upgrade to CF 4.5 complains about "could not find nokogiri-1.6.8" during "rake db:migrate"
upgrade to CF 4.5 complains about "could not find nokogiri-1.6.8" during "rak...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Build (Show other bugs)
5.8.0
All All
unspecified Severity high
: GA
: 5.8.1
Assigned To: Satoe Imaishi
luke couzens
black:upgrade:migration
: ZStream
: 1469015 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-06 17:24 EDT by Ryan Spagnola
Modified: 2017-09-21 03:25 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.8.1.0
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-02 13:33:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: Bug
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: CFME Core


Attachments (Terms of Use)

  None (edit)
Description Ryan Spagnola 2017-07-06 17:24:32 EDT
Description of problem:
09:37:19 [/var/www/miq/vmdb]$ rake db:migrate
Could not find nokogiri-1.6.8 in any of the sources
Run `bundle install` to install missing gems.

09:39:04 [/var/www/miq/vmdb]$ rpm -qa | grep nokogiri
rh-ruby23-rubygem-nokogiri-1.7.2-1.el7cf.x86_64
rh-ruby22-rubygem-nokogiri-1.6.6.2-3.el7cf.x86_64

------------------------------------------------------------------------------   


Version-Release number of selected component (if applicable):
5.7.3
5.8.x

How reproducible:
Always

Steps to Reproduce:
1. follow doc for upgrading from 5.7 to 5.8
2.
3.

Actual results:
missing gem error

Expected results:
successful upgrade to 5.8

Additional info:
Upgrading from 5.7.2 works fine. This issue only appears when upgrading from 5.7.3
Comment 2 luke couzens 2017-07-07 05:41:31 EDT
Hey Ryan,

Is there any extra info you could give on this?

I have tried on 6 appliances now and none are seeing this issue.

What version did you update to 5.8.1.0?

Thanks,
Luke
Comment 3 myoder 2017-07-07 19:50:17 EDT
Hey Luke,

We have no problem upgrading from 5.7.2 to 5.8.0.   The problem is only going from 5.7.3 to 5.8.0.


5.7.3 seems to install this as a prereq:
	rh-ruby23-rubygem-nokogiri-1.7.2-1.el7cf.x86_64


But, 5.8.0 has a lower version.
	rh-ruby23-rubygem-nokogiri-1.6.8-1.el7cf.x86_64

Best,
Yoder
Comment 4 luke couzens 2017-07-10 05:07:19 EDT
Hi Yoder,

I see the same thing now on 5.7.3.2 to 5.8.0.17.

Originally I was testing 5.7.3.2 - 5.8.1 as the bz just said 5.8.z,
so thanks for the clarification.
Comment 5 Satoe Imaishi 2017-07-10 11:45:09 EDT
*** Bug 1469015 has been marked as a duplicate of this bug. ***
Comment 6 Satoe Imaishi 2017-07-10 14:43:03 EDT
The workaround is to run "yum downgrade rh-ruby23-rubygem-nokogiri-1.6.8-1.el7cf.x86_64" after "yum update".
Comment 9 luke couzens 2017-07-19 06:53:01 EDT
Verified in 5.8.1.2
Comment 13 errata-xmlrpc 2017-08-02 13:33:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHSA-2017:1758

Note You need to log in before you can comment on or make changes to this bug.