Bug 1469015 - rh-ruby23-rubygem-nokogiri version mismatch in cfme-5.7.2.1 and cfme-5.7.3.2
rh-ruby23-rubygem-nokogiri version mismatch in cfme-5.7.2.1 and cfme-5.7.3.2
Status: CLOSED DUPLICATE of bug 1468376
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Build (Show other bugs)
5.7.0
Unspecified Unspecified
unspecified Severity medium
: GA
: cfme-future
Assigned To: Satoe Imaishi
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-10 05:11 EDT by Sachin
Modified: 2017-07-10 11:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-10 11:45:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sachin 2017-07-10 05:11:14 EDT
Description of problem:

cfme-5.7.2.1
============
# rpm -qa | grep nokogiri
rh-ruby23-rubygem-nokogiri-1.6.8-1.el7cf.x86_64


cfme-5.7.3.2
============
rh-ruby23-rubygem-nokogiri version is 1.7.2-1[1]

[1] https://access.redhat.com/downloads/content/cf-me---4.2/x86_64/5638/rh-ruby23-rubygem-nokogiri/1.7.2-1.el7cf/x86_64/fd431d51/package


cfme-5.8.0.17
=============
# rpm -qa | grep nokogiri
rh-ruby23-rubygem-nokogiri-1.6.8-1.el7cf.x86_64


If cf-4.2(cfme-5.7.3.2) is upgraded to cf-4.5 it throw below warning
~~~
Bundler::GemNotFound: Could not find nokogiri-1.6.8 in any of the sources

version nokogiri-1.7.2 is being installed and not the 1.6.8 version
~~~


Workaround:
-----------
Manually remove nokogiri-1.7.2 package and install 1.6.8


Version-Release number of selected component (if applicable):
5.7.3.2


How reproducible:
Always

Steps to Reproduce:
See description


Actual results:


Expected results:


Additional info:
Comment 2 Satoe Imaishi 2017-07-10 10:21:25 EDT
Between cfme-5.7.2.1 and cfme-5.7.3.2, it's not a mismatch, but just an update.

Between 5.7.3 and 5.8.0 is a different issue (and valid) - that's tracked under bug #1468376.
Comment 3 Satoe Imaishi 2017-07-10 11:45:09 EDT

*** This bug has been marked as a duplicate of bug 1468376 ***

Note You need to log in before you can comment on or make changes to this bug.