Bug 1468556 - "Filter:true" hard coded in fence_rhevm prevents oVirt 3 connection
"Filter:true" hard coded in fence_rhevm prevents oVirt 3 connection
Status: CLOSED DUPLICATE of bug 1422499
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: fence-agents (Show other bugs)
7.3
All Linux
unspecified Severity medium
: rc
: ---
Assigned To: Marek Grac
cluster-qe@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-07 08:05 EDT by Nicolas Ecarnot
Modified: 2017-07-07 09:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-07 09:18:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Ecarnot 2017-07-07 08:05:22 EDT
Description of problem:
Using fence_rhevm with an oVirt 3.6 engine is failing with the error "Failed: Unable to obtain correct plug status or plug is not available".

Version-Release number of selected component (if applicable):
- RHEL 7.3 client (fence_rhevm source)
- oVirt 3.6.7 on RHEL 7.2 (fence_rhevm target)
- fence-agents-rhevm-4.0.11-47.el7_3.5.x86_64 is failing
- fence-agents-rhevm-4.0.11-27.el7_2.7.x86_64 was working

How reproducible:
Always

Steps to Reproduce:
1. Run :
fence_rhevm -a ovirt-engine -o status -l 'admin@internal' -p 'xxx' --ssl -n vm01 --ssl-insecure

Actual results:
Failed: Unable to obtain correct plug status or plug is not available

Expected results:
With fence-agents-rhevm-4.0.11-27, the result is "Status: ON".

Additional info:
This patch (https://github.com/ClusterLabs/fence-agents/pull/71/commits) added the hard-coded "Filter:true" into the HTTPHEADER connection options.
I tried with the admin@internal of with a dedicated user (with superuser rights).
In every cases, I get a connection in my engine logs, but the failing replies (see above).

When manually removing this Filter:true option, every command are working successfully.

This patch came after this BZ : https://bugzilla.redhat.com/show_bug.cgi?id=1287059

AFAIR, this Filter header was made mandatory on oVirt 4.x generation.
It is a blocker for us people who are still maintaining oVirt 3.x stable DCs.
This would be nice to make this header optional (or better auto-detect).

Best regards.
Comment 2 Marek Grac 2017-07-07 09:18:41 EDT
Hi,

We are aware of this issue and you can use 'disable_http_filter' (or --disable-http-filter from the command line). 

The patch is available in upstream and should be part of the next minor release. If you need to have an official package sooner, feel free to open customer's ticket.

*** This bug has been marked as a duplicate of bug 1422499 ***

Note You need to log in before you can comment on or make changes to this bug.