Bug 146880 - Wrong install scripts in gnome-applets-2.9.5-1
Wrong install scripts in gnome-applets-2.9.5-1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-02 09:23 EST by sangu
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.9.5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-04 11:06:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sangu 2005-02-02 09:23:28 EST
Description of problem:
$rpm -qp --scripts gnome-applets-2.9.5-1.i386.rpm
postinstall scriptlet (using /bin/sh):
/sbin/ldconfig
scrollkeeper-update

export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="battstat.schemas"
SCHEMAS="$SCHEMAS charpick.schemas drivemount.schemas geyes.schemas gkb.schemas
gtik.schemas gweather.schemas mailcheck.schemas mini-commander.schemas
mixer.schemas modemlights.schemas multiload.schemas stickynotes.schemas
gswitchit.schemas"
for S in $SCHEMAS; do
  gconftool-2 --makefile-install-rule /etc/gconf/schemas/$S > /dev/null
done
/usr/libexec/gnome-applets/mc-install-default-macros > /dev/null
postuninstall program: /sbin/ldconfig

"modemlights.schemas" file isn't in gnome-applets.
and  mini-commander-global.schemas isn't in scripts

$rpm -qpl gnome-applets-2.9.5-1*.rpm | grep modemlights.schemas
no file
$rpm -qpl gnome-applets-2.9.5-1*.rpm | grep mini-dommander-global.schemas
/etc/gconf/schemas/mini-commander-global.schemas

Version-Release number of selected component (if applicable):
gnome-applets-2.9.5-1

How reproducible:
always

Steps to Reproduce:
1. rpm -Uhv gnome-applets-2.9.5-1.i386.rpm
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mark McLoughlin 2005-02-02 12:38:46 EST
mclasen: looks like $SCHEMAS needs to be changed after the upgrade

needs to be removed:
  modemlights.schemas
  gkb.schemas
  mailcheck.schemas

needs to be added:
  cpufreq-applet.schemas
  mini-commander-global.schemas
Comment 2 Michal Jaegermann 2005-02-03 23:10:51 EST
This is a bug with a pretty long standing.  See bug #122379.
I proposed there a simple script modification which can
be easily changed to run through all existing files in
/etc/gconf/schemas/*.schemas and then it will not depend on somebody
remembering to update that list or not.  If some exceptions are
needed they are surely easier to handle then a "normal" list.
Comment 3 Mark McLoughlin 2005-02-04 10:58:14 EST
Yeah, it would be nice if we didn't have to keep the static list of
schemas up to date. The problem is, this is in %post so I don't think
you can easily figure out what .schema files we've just installed. 

Probably the only way you could do it is by generating a list of
schemas at build time and including that list in a file in the package
or somehow consulting the rpmdb during %post. With the former, we'd
have a redundant file which would be ugly. And I'm pretty sure you're
not supposed to do the latter.
Comment 4 Mark McLoughlin 2005-02-04 11:06:59 EST
Should be fixed in 2.9.5-2 which is on its way

Note You need to log in before you can comment on or make changes to this bug.