Bug 1468836 - ImportError: No module named koji
Summary: ImportError: No module named koji
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpkg
Version: rawhide
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
Assignee: cqi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1469797 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-08 16:29 UTC by Igor Gnatenko
Modified: 2017-07-31 03:27 UTC (History)
8 users (show)

Fixed In Version: rpkg-1.49-6.fc26 rpkg-1.49-6.fc25 rpkg-1.49-6.el6 rpkg-1.49-6.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-17 04:51:54 UTC
Type: Bug


Attachments (Terms of Use)

Description Igor Gnatenko 2017-07-08 16:29:28 UTC
python2-rpkg-1.49-5.fc27.noarch

Since 1.13, koji was split to python2-koji and python3-koji, so Requires should be adjusted to use that.

P.S. not sure about EPEL

Comment 1 cqi 2017-07-10 02:58:15 UTC
Hi Igor, thanks for reporting this. Good to see this big step forward in koji. I'll start to rebuild rpkg with koji 1.13 ASAP.

BTW, I checked koji and bodhi, there are koji 1.13 packages for EPEL (el6 and epel7).

Comment 2 Fedora Update System 2017-07-10 06:50:28 UTC
rpkg-1.49-6.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-99f88c2382

Comment 3 Fedora Update System 2017-07-12 03:46:19 UTC
rpkg-1.49-6.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-78ab2b5c00

Comment 4 Fedora Update System 2017-07-12 05:28:09 UTC
rpkg-1.49-6.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-cc3aa68a6f

Comment 5 Lubomír Sedlář 2017-07-12 05:30:21 UTC
*** Bug 1469797 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2017-07-12 08:36:27 UTC
rpkg-1.49-6.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-99f88c2382

Comment 7 Fedora Update System 2017-07-12 09:24:14 UTC
rpkg-1.49-6.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-518caf0580

Comment 8 Fedora Update System 2017-07-17 04:51:54 UTC
rpkg-1.49-6.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2017-07-25 21:22:29 UTC
rpkg-1.49-6.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2017-07-28 02:47:12 UTC
rpkg-1.49-6.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2017-07-28 02:49:55 UTC
rpkg-1.49-6.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Gonéri Le Bouder 2017-07-29 04:19:06 UTC
There is no python2-koji in EPEL. This change breaks rpkg.

Comment 13 cqi 2017-07-31 03:27:30 UTC
python2-koji has been available in epel7, and el6 build[1] is still in testing phase in bodhi.

[1] https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-1b53c89a2c


Note You need to log in before you can comment on or make changes to this bug.