Bug 1469797 - fedpkg: ImportError: No module named koji
fedpkg: ImportError: No module named koji
Status: CLOSED DUPLICATE of bug 1468836
Product: Fedora
Classification: Fedora
Component: fedpkg (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: cqi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 16:56 EDT by Lukas Slebodnik
Modified: 2017-07-12 01:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-12 01:30:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Slebodnik 2017-07-11 16:56:53 EDT
Description of problem:
I upgraded my laptop from f26 to f27 and fedpkg does not work after upgrade

Version-Release number of selected component (if applicable):
sh$ rpm -q fedpkg
fedpkg-1.28-1.fc26.noarch

How reproducible:
deterministic

Steps to Reproduce:
1. fedpkg clone --anonymous mock

Actual results:
Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 13, in <module>
    from fedpkg.__main__ import main
  File "/usr/lib/python2.7/site-packages/fedpkg/__init__.py", line 12, in <module>
    import pyrpkg
  File "/usr/lib/python2.7/site-packages/pyrpkg/__init__.py", line 17, in <module>
    import koji
ImportError: No module named koji

Expected results:
No problems

Additional info:
sh$ rpm -qa | grep koji
python3-koji-1.13.0-1.fc27.noarch
koji-1.13.0-1.fc27.noarch

sh$ rpm -q --requires fedpkg 
/usr/bin/python
bodhi-client
config(fedpkg) = 1.28-1.fc26
fedora-cert
koji
packagedb-cli
packagedb-cli > 2.2
pyrpkg >= 1.47
python(abi) = 2.7
python-fedora
python-pycurl
redhat-rpm-config
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1
Comment 1 Lubomír Sedlář 2017-07-12 01:30:21 EDT

*** This bug has been marked as a duplicate of bug 1468836 ***

Note You need to log in before you can comment on or make changes to this bug.