Bug 1469109 - Stop sending hosts statistics to statsd except storage
Stop sending hosts statistics to statsd except storage
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
4.20.0
Unspecified Unspecified
high Severity high (vote)
: ovirt-4.2.0
: 4.20.3
Assigned To: Yaniv Bronhaim
Lukas Svaty
:
Depends On:
Blocks: 1469104
  Show dependency treegraph
 
Reported: 2017-07-10 08:21 EDT by Shirly Radco
Modified: 2017-12-20 06:08 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:08:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+
lsvaty: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 80050 master MERGED metrics: stop sending host metrics except storage 2017-08-29 06:04 EDT

  None (edit)
Description Shirly Radco 2017-07-10 08:21:34 EDT
Description of problem:
Host statistics should be collected from the various collectd plugins.
Currently, vdsm also send hosts metrics through statsd plugin.
We should remove the hosts statistics from the metrics that vdsm sends to collectd statsd plugin.
Comment 1 Lukas Svaty 2017-10-09 05:49:57 EDT
only statsd record is host_storage

verified in ovirt-engine-metrics-1.1.1-0.0.master.20171001113530.el7.centos.noarch
Comment 2 Lukas Svaty 2017-10-09 05:55:50 EDT
apologies, wrong package, SanityOnly in vdsm-4.20.3-144.git71c9cb6.el7.centos.x86_64
Comment 3 Sandro Bonazzola 2017-12-20 06:08:43 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.