Bug 1469119 - Disable collectd virt plugin
Disable collectd virt plugin
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine-metrics
Classification: oVirt
Component: Generic (Show other bugs)
1.0.5
Unspecified Unspecified
unspecified Severity medium
: ovirt-4.2.0
: ---
Assigned To: Shirly Radco
Lukas Svaty
:
Depends On: 1463278
Blocks: oVirt-Metrics-and-Logs 1473163 1473164 1473171 1474354 1475135
  Show dependency treegraph
 
Reported: 2017-07-10 08:31 EDT by Shirly Radco
Modified: 2017-12-20 06:28 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-20 06:28:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Metrics
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.2+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79543 master MERGED remove collectd-virt from CheckUpdate 2017-07-25 01:40 EDT
oVirt gerrit 79544 None None None 2017-07-18 04:46 EDT
oVirt gerrit 79546 master ABANDONED Do not install collectd-virt package 2017-07-19 09:23 EDT
oVirt gerrit 79548 master MERGED remove collectd-virt plugin collection 2017-07-20 09:27 EDT
oVirt gerrit 79626 master MERGED Do not install collectd-virt package 2017-07-20 03:41 EDT

  None (edit)
Description Shirly Radco 2017-07-10 08:31:01 EDT
Description of problem:
Currently, libvirt statistics are collected both by vdsm and by collectd virt plugin.

vdsm collects more statistics ate this point, so in order to avoid unnecessary overhead we want to stop collecting statistics from the virt plugin.

Once the new collectd virt plugin will be released we will consider reusing the plugin.
Comment 1 Shirly Radco 2017-07-17 16:24:37 EDT
virt plugin automatically adds /etc/collectd.d/libvirt.conf.
This file includes "LoadPlugin libvirt".
In order do disable the virt plugin we need to disable this file as well.

Should we remove this file or comment out the line?
Comment 2 Yedidyah Bar David 2017-07-18 01:43:51 EDT
(In reply to Shirly Radco from comment #1)
> virt plugin automatically adds /etc/collectd.d/libvirt.conf.

If we do not want it, perhaps best to not install it, no?

> This file includes "LoadPlugin libvirt".
> In order do disable the virt plugin we need to disable this file as well.

Is it a problem, if it's loaded? Or just some waste of resources?
If it's a problem, we should prevent installing collectd-virt,
perhaps by checking its existence in ovirt-metrics and failing if
it's installed, or by conflicting with it in the ovirt-host package
we are going to have.

> 
> Should we remove this file or comment out the line?

I do not think we should touch this file at all.

If you think the collectd-virt package should not provide it, or
should provide it with a commented line, open a bug against collectd.

Users can also install other collectd plugins. We should either make
sure this is not causing problems, or check and alert/fail/etc.
Comment 3 Shirly Radco 2017-07-18 02:05:18 EDT
(In reply to Yedidyah Bar David from comment #2)
> (In reply to Shirly Radco from comment #1)
> > virt plugin automatically adds /etc/collectd.d/libvirt.conf.
> 
> If we do not want it, perhaps best to not install it, no?

In some machines it is already installed.
We may hit this situation in the future as well with other plugins. I don't think we can do that.
Perhaps uninstall the package? But I think that it is a dependency so not sure its possible.

> 
> > This file includes "LoadPlugin libvirt".
> > In order do disable the virt plugin we need to disable this file as well.
> 
> Is it a problem, if it's loaded? Or just some waste of resources?
> If it's a problem, we should prevent installing collectd-virt,
> perhaps by checking its existence in ovirt-metrics and failing if
> it's installed, or by conflicting with it in the ovirt-host package
> we are going to have.


Its a waste of resources. Why should collectd collect and send the stats every 10 seconds? Its also loading libvirt without any good reason.

We may want to use the new virt plugin that Franchesco did ,once it is release in collectd. Probably not before 5.8.0.


> 
> > 
> > Should we remove this file or comment out the line?
> 
> I do not think we should touch this file at all.
> 
> If you think the collectd-virt package should not provide it, or
> should provide it with a commented line, open a bug against collectd.
> 
> Users can also install other collectd plugins. We should either make
> sure this is not causing problems, or check and alert/fail/etc.

I don't think we will support adding additional plugins. Yaniv?
Comment 4 Yedidyah Bar David 2017-07-18 02:46:10 EDT
(In reply to Shirly Radco from comment #3)
> (In reply to Yedidyah Bar David from comment #2)
> > (In reply to Shirly Radco from comment #1)
> > > virt plugin automatically adds /etc/collectd.d/libvirt.conf.
> > 
> > If we do not want it, perhaps best to not install it, no?
> 
> In some machines it is already installed.

It's already installed on _all_ machines (hosts) currently. ovirt-host-deploy does that.

Perhaps start by not installing it by host-deploy.

Then we can consider if it's important to clean up after ourselves during
upgrades and how.

This is considered "tech preview" IIUC, so perhaps it's enough if we document how to clean up, instead of having code to do this.

> We may hit this situation in the future as well with other plugins. I don't
> think we can do that.
> Perhaps uninstall the package? But I think that it is a dependency so not
> sure its possible.

Dependency of what?

> 
> > 
> > > This file includes "LoadPlugin libvirt".
> > > In order do disable the virt plugin we need to disable this file as well.
> > 
> > Is it a problem, if it's loaded? Or just some waste of resources?
> > If it's a problem, we should prevent installing collectd-virt,
> > perhaps by checking its existence in ovirt-metrics and failing if
> > it's installed, or by conflicting with it in the ovirt-host package
> > we are going to have.
> 
> 
> Its a waste of resources. Why should collectd collect and send the stats
> every 10 seconds?

But how can you know if it's loaded because we installed it, or because the user manually did?

> Its also loading libvirt without any good reason.
> 
> We may want to use the new virt plugin that Franchesco did ,once it is
> release in collectd. Probably not before 5.8.0.
> 
> 
> > 
> > > 
> > > Should we remove this file or comment out the line?
> > 
> > I do not think we should touch this file at all.
> > 
> > If you think the collectd-virt package should not provide it, or
> > should provide it with a commented line, open a bug against collectd.
> > 
> > Users can also install other collectd plugins. We should either make
> > sure this is not causing problems, or check and alert/fail/etc.
> 
> I don't think we will support adding additional plugins. Yaniv?

I'd say this is a bit restrictive. We have ovirt-node for people that want a pre-prepared system. We do support also a full OS, for those that want more control, no? You could also decide that you do not support conf.d, just write out a single large conf file, but decided not to.
Comment 5 Shirly Radco 2017-07-18 04:00:10 EDT
As mentioned in bug 1463278 we will not install the plugin in new installation, for upgrade we will add documentation to suggest to the user to cleanup the package and file.
Comment 6 Lukas Svaty 2017-09-04 04:20:46 EDT
verified in ovirt-engine-metrics-1.1.1-0.0.master.20170813121239.el7.centos.noarch
Comment 7 Sandro Bonazzola 2017-12-20 06:28:38 EST
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.

Note You need to log in before you can comment on or make changes to this bug.