Bug 1469282 - tracer-common should require python3-argcomplete
tracer-common should require python3-argcomplete
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tracer (Show other bugs)
27
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Kadlčík
Fedora Extras Quality Assurance
: Reopened
: 1504474 1505471 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-10 16:26 EDT by Kevin Fenzi
Modified: 2018-05-09 12:13 EDT (History)
10 users (show)

See Also:
Fixed In Version: tracer-0.7.0-1.fc26 tracer-0.7.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-30 18:02:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2017-07-10 16:26:58 EDT
tracer-common installs a: 

/etc/bash_completion.d/tracer file that contains: 

eval "$(register-python-argcomplete tracer)"

register-python-argcomplete is in the python3-argcomplete package, if it's not installed, every login gives you: 

bash: register-python-argcomplete: command not found
Comment 1 Jakub Kadlčík 2017-07-10 23:50:20 EDT
Thank you Kevin,
this is already fixed in upstream.

New release needs to be done.
Comment 2 Fedora Update System 2017-07-11 05:20:37 EDT
tracer-0.6.13-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-19e5b97629
Comment 3 Fedora Update System 2017-07-11 05:20:43 EDT
tracer-0.6.13-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-a78a7cee02
Comment 4 Fedora Update System 2017-07-11 05:20:48 EDT
tracer-0.6.13-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-0e8d47812d
Comment 5 Fedora Update System 2017-07-12 01:23:20 EDT
tracer-0.6.13-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-a78a7cee02
Comment 6 Fedora Update System 2017-07-12 01:29:00 EDT
tracer-0.6.13-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-0e8d47812d
Comment 7 Fedora Update System 2017-07-12 04:37:42 EDT
tracer-0.6.13-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-19e5b97629
Comment 8 Fedora Update System 2017-07-26 08:46:59 EDT
tracer-0.6.13-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-6aed43ddbe
Comment 9 Fedora Update System 2017-07-26 19:17:27 EDT
tracer-0.6.13-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-6aed43ddbe
Comment 10 Fedora Update System 2017-08-01 16:02:52 EDT
python-argcomplete-1.7.0-2.el7 tracer-0.6.13-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-6aed43ddbe
Comment 11 Fedora Update System 2017-08-02 17:19:19 EDT
python-argcomplete-1.7.0-2.el7, tracer-0.6.13-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-6aed43ddbe
Comment 12 Jan Kurik 2017-08-15 05:17:51 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 27 development cycle.
Changing version to '27'.
Comment 13 Fedora Update System 2017-08-21 10:43:16 EDT
tracer-0.6.13-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-1ea755452d
Comment 14 Fedora Update System 2017-08-23 02:33:32 EDT
tracer-0.6.13-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-1ea755452d
Comment 15 Fedora Update System 2017-09-06 10:49:34 EDT
tracer-0.6.13-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2017-09-11 17:59:13 EDT
tracer-0.6.13.1-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-037d9e0cd3
Comment 17 Fedora Update System 2017-09-11 17:59:21 EDT
tracer-0.6.13.1-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-fa8f3ad48e
Comment 18 Fedora Update System 2017-09-11 21:24:26 EDT
tracer-0.6.13.1-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-037d9e0cd3
Comment 19 Fedora Update System 2017-09-11 22:21:55 EDT
tracer-0.6.13.1-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-fa8f3ad48e
Comment 20 Kamil Páral 2017-09-12 06:50:38 EDT
This is not correctly fixed. First of all, /etc/bash_completion.d/tracer is included in tracer-common, but tracer-common does not have any real requires:

$ rpm -ql tracer-common
/etc/bash_completion.d/tracer
...

$ rpm -q --requires tracer-common 
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(PayloadIsXz) <= 5.2-1

So if you have just tracer-common, you'll still encounter this bug.

Second, the requires is in python3-tracer, but incorrect:
$ rpm -q --requires python3-tracer
python-argcomplete
...

It should be python3-argcomplete.

$ dnf provides **/register-python-argcomplete
python3-argcomplete-1.8.2-2.fc26.noarch : Bash tab completion for argparse
Repo        : fedora


So either make tracer-common require python3-argcomplete, or move the bash completion file to python3-tracer (and make it require python3-argcomplete).


python3-tracer-0.6.13.1-1.fc26.noarch
python2-tracer-0.6.13.1-1.fc26.noarch
tracer-common-0.6.13.1-1.fc26.noarch
Comment 21 Sean O'Keeffe 2017-09-12 07:08:02 EDT
Would this be because its using Suggests? https://github.com/FrostyX/tracer/blob/master/tracer.spec#L92

We might have to let make the bash completion script exit cleanly if register-python-argcomplete isn't available.
Comment 22 Kamil Páral 2017-09-12 07:53:10 EDT
(In reply to Sean O'Keeffe from comment #21)
> Would this be because its using Suggests?
> https://github.com/FrostyX/tracer/blob/master/tracer.spec#L92

This is the Fedora specfile:
https://src.fedoraproject.org/rpms/tracer/blob/master/f/tracer.spec#_64

But as you can see in the rpm output above, the package is actually using requires. Not sure how to explain that.

> We might have to let make the bash completion script exit cleanly if
> register-python-argcomplete isn't available.

That's also a valid approach.
Comment 23 Fedora Update System 2017-10-02 17:52:00 EDT
tracer-0.6.13.1-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-bb97b4d465
Comment 24 Fedora Update System 2017-10-02 17:52:14 EDT
tracer-0.6.13.1-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-98104623b5
Comment 25 Fedora Update System 2017-10-05 23:22:33 EDT
tracer-0.6.13.1-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-98104623b5
Comment 26 Fedora Update System 2017-10-05 23:24:37 EDT
tracer-0.6.13.1-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-bb97b4d465
Comment 27 Kamil Páral 2017-10-27 08:25:16 EDT
*** Bug 1505471 has been marked as a duplicate of this bug. ***
Comment 28 Jean-Claude 2017-12-17 05:29:50 EST
Same problem on Fedora 27 :

-bash: register-python-argcomplete: command not found
[root@XXXX ~]# grep -r register-python-argcomplete /etc/
/etc/bash_completion.d/tracer:eval "$(register-python-argcomplete tracer)"
tracer-common-0.6.13-2.fc27.noarch
[root@XXXX ~]# rpm -qif /etc/bash_completion.d/tracer
Name        : tracer-common
Version     : 0.6.13
Release     : 2.fc27
Architecture: noarch
Install Date: dim. 03 déc. 2017 16:29:33 CET
Group       : Unspecified
Size        : 33930
License     : GPLv2+
Signature   : RSA/SHA256, ven. 28 juil. 2017 05:15:32 CEST, Key ID f55e7430f5282ee4
Source RPM  : tracer-0.6.13-2.fc27.src.rpm
Build Date  : ven. 28 juil. 2017 02:54:23 CEST
Build Host  : buildvm-armv7-05.arm.fedoraproject.org
Relocations : (not relocatable)
Packager    : Fedora Project
Vendor      : Fedora Project
URL         : http://tracer-package.com/
Summary     : Common files for tracer
Description :
Common files for tracer.


"dnf -y install python3-argcomplete python3-tracer" remove the message when bash start.
Comment 29 Dominik 'Rathann' Mierzejewski 2017-12-19 05:58:53 EST
*** Bug 1504474 has been marked as a duplicate of this bug. ***
Comment 30 Dominik 'Rathann' Mierzejewski 2017-12-19 06:02:21 EST
(In reply to Kamil Páral from comment #22)
> (In reply to Sean O'Keeffe from comment #21)
> > Would this be because its using Suggests?
> > https://github.com/FrostyX/tracer/blob/master/tracer.spec#L92
> 
> This is the Fedora specfile:
> https://src.fedoraproject.org/rpms/tracer/blob/master/f/tracer.spec#_64
> 
> But as you can see in the rpm output above, the package is actually using
> requires. Not sure how to explain that.

No, it's using Suggests:

https://src.fedoraproject.org/rpms/tracer/blob/master/f/tracer.spec#_65
https://src.fedoraproject.org/rpms/tracer/blob/master/f/tracer.spec#_92

I'd use Recommends here, anyway. Suggests are not pulled in by default by dnf.

> > We might have to let make the bash completion script exit cleanly if
> > register-python-argcomplete isn't available.
> 
> That's also a valid approach.

Indeed.
Comment 31 Dominik 'Rathann' Mierzejewski 2017-12-19 06:05:48 EST
(In reply to Kamil Páral from comment #20)
> So either make tracer-common require python3-argcomplete, or move the bash
> completion file to python3-tracer (and make it require python3-argcomplete).

Seconded. This is still not fixed in Fedora 26 and 27. I haven't checked EPEL.
Comment 32 Fedora Update System 2018-04-19 17:03:57 EDT
tracer-0.7.0-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-b437cce027
Comment 33 Fedora Update System 2018-04-19 18:37:45 EDT
tracer-0.7.0-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-e2c57717ce
Comment 34 Fedora Update System 2018-04-21 00:37:48 EDT
tracer-0.7.0-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-b437cce027
Comment 35 Fedora Update System 2018-04-21 02:19:01 EDT
tracer-0.7.0-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-e2c57717ce
Comment 36 Fedora Update System 2018-04-23 04:38:14 EDT
tracer-0.7.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-5d15a730d8
Comment 37 Fedora Update System 2018-04-24 00:46:34 EDT
tracer-0.7.0-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-5d15a730d8
Comment 38 Kamil Páral 2018-04-27 11:13:48 EDT
Seems to be fixed in 0.7.0-1.fc28.
Comment 39 Fedora Update System 2018-04-30 18:02:22 EDT
tracer-0.7.0-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 40 Fedora Update System 2018-05-09 12:13:32 EDT
tracer-0.7.0-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.