Bug 1469291 - Missing node level memory/usage [NEEDINFO]
Summary: Missing node level memory/usage
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Hawkular
Version: 3.5.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.z
Assignee: John Sanda
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1473363 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-10 21:26 UTC by Matt Wringe
Modified: 2017-12-14 21:01 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1441390
Environment:
Last Closed: 2017-12-14 21:01:55 UTC
Target Upstream Version:
juzhao: needinfo? (pweil)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Issue Tracker HWKMETRICS-678 Major Resolved Failure to insert metric tags can result in inconsistent state 2018-03-05 09:48:20 UTC
Red Hat Product Errata RHBA-2017:3438 normal SHIPPED_LIVE OpenShift Container Platform 3.6 and 3.5 bug fix and enhancement update 2017-12-15 01:58:11 UTC

Comment 1 Matt Wringe 2017-07-10 21:28:14 UTC
Can we get this backported in Hawkular Metrics for our OCP 3.5 version?

Comment 5 Matt Wringe 2017-08-09 21:07:55 UTC
*** Bug 1473363 has been marked as a duplicate of this bug. ***

Comment 10 Junqi Zhao 2017-10-09 00:11:53 UTC
@pweil

Please help to verify this defect.
Thanks

Comment 11 Junqi Zhao 2017-11-15 00:10:56 UTC
@pweil

Can you show me the details on how to verify this defect?

Comment 12 Junqi Zhao 2017-11-29 01:57:08 UTC
Images:
metrics-cassandra-3.5.0-49
metrics-hawkular-metrics-3.5.0-58
metrics-heapster-3.5.0-41

# openshift version
openshift v3.5.5.31.47
kubernetes v1.5.2+43a9be4
etcd 3.1.0

Tested on 7 nodes, and created a few projects and every node had at least one running pod, let the metrics run for a day, all metrics usage could be found in metrics web console

Used the following command to check memory/usage on every node, it's not missed.

# curl -k -H "Authorization: Bearer $TOKEN" -H "Hawkular-tenant: _system" https://metrics.newscorpau01.openshift.com/hawkular/metrics/metrics?tags=nodename:${NODE} | python -m json.tool | grep -i \"id\" | grep -i machine | grep -i memory | sort

        "id": "machine/${NODE}/memory/limit",
        "id": "machine/${NODE}/memory/major_page_faults",
        "id": "machine/${NODE}/memory/major_page_faults_rate",
        "id": "machine/${NODE}/memory/node_capacity",
        "id": "machine/${NODE}/memory/node_reservation",
        "id": "machine/${NODE}/memory/node_utilization",
        "id": "machine/${NODE}/memory/page_faults",
        "id": "machine/${NODE}/memory/page_faults_rate",
        "id": "machine/${NODE}/memory/request",
        "id": "machine/${NODE}/memory/usage",
        "id": "machine/${NODE}/memory/working_set",

Comment 15 errata-xmlrpc 2017-12-14 21:01:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3438


Note You need to log in before you can comment on or make changes to this bug.