This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1473363 - Some Hawkular metrics without tag metadata
Some Hawkular metrics without tag metadata
Status: CLOSED DUPLICATE of bug 1469291
Product: OpenShift Container Platform
Classification: Red Hat
Component: Metrics (Show other bugs)
3.5.0
Unspecified Unspecified
high Severity high
: ---
: 3.5.z
Assigned To: Matt Wringe
Junqi Zhao
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-20 11:32 EDT by Javier Ramirez
Modified: 2017-08-09 17:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-09 17:07:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Javier Ramirez 2017-07-20 11:32:38 EDT
Description of problem:

Some Hawkular metrics do not have metadata in the "tags" dictionary.
This causes troubles when trying to create graphs filtering by some of this tags.

Version-Release number of selected component (if applicable):
registry.access.redhat.com/openshift3/metrics-cassandra          3.5.0               
registry.access.redhat.com/openshift3/metrics-hawkular-metrics   3.5.0               
registry.access.redhat.com/openshift3/metrics-heapster           3.5.0               

How reproducible:
Always


Steps to Reproduce:
1. Deploy metrics 3.5.0
2. Use curl command as:
curl -sH "Hawkular-Tenant: logging"  -H 'Authorization: Bearer XXX' "https://hawkular-metrics.example/hawkular/metrics/gauges/fluentd-elasticsearch%2F46e45c6b-46d5-11e7-b994-005056a23f44%2Fmemory%2Fusage" | jq .

3.

Actual results:
Some of the metrics do not include metadata:
Metric with correct metadata:
$ curl -sH "Hawkular-Tenant: logging"  -H 'Authorization: Bearer XXX' "https://hawkular-metrics.apps-dev.hi.inet/hawkular/metrics/gauges/elasticsearch%2Fad61ea58-6637-11e7-89ec-005056a24ea1%2Fmemory%2Fusage" | jq .
{
  "id": "elasticsearch/ad61ea58-6637-11e7-89ec-005056a24ea1/memory/usage",
  "tags": {
    "container_base_image": "registry.access.redhat.com/openshift3/logging-elasticsearch:3.5.0",
    "container_name": "elasticsearch",
    "descriptor_name": "memory/usage",
    "group_id": "elasticsearch/memory/usage",
    "host_id": "prod-epg-ocpi-03.hi.inet",
    "hostname": "prod-epg-ocpi-03.hi.inet",
    "labels": "component:es,deployment:logging-es-6uiyr7lz-2,deploymentconfig:logging-es-6uiyr7lz,logging-infra:elasticsearch,provider:openshift",
    "namespace_id": "6c43dbd5-4554-11e7-ab6a-005056a24ea1",
    "namespace_name": "logging",
    "nodename": "prod-epg-ocpi-03.hi.inet",
    "pod_id": "ad61ea58-6637-11e7-89ec-005056a24ea1",
    "pod_name": "logging-es-6uiyr7lz-2-fwq6s",
    "pod_namespace": "logging",
    "type": "pod_container",
    "units": "bytes"
  },
  "dataRetention": 7,
  "type": "gauge",
  "tenantId": "logging",
  "minTimestamp": 1500293520000,
  "maxTimestamp": 1500296700000
}


Metric with missing metadata:
$ curl -sH "Hawkular-Tenant: logging"  -H 'Authorization: Bearer XXX' "https://hawkular-metrics.apps-dev.hi.inet/hawkular/metrics/gauges/fluentd-elasticsearch%2F46e45c6b-46d5-11e7-b994-005056a23f44%2Fmemory%2Fusage" | jq .
{
  "id": "fluentd-elasticsearch/46e45c6b-46d5-11e7-b994-005056a23f44/memory/usage",
  "dataRetention": 7,
  "type": "gauge",
  "tenantId": "logging",
  "minTimestamp": 1499688000000,
  "maxTimestamp": 1500297090000
}


Expected results:
All metrics including metadata

Additional info:
Comment 4 Matt Wringe 2017-08-09 17:07:55 EDT

*** This bug has been marked as a duplicate of bug 1469291 ***

Note You need to log in before you can comment on or make changes to this bug.