Bug 1469355 - RGW : Crashed when system user was used for swift DLO operations
RGW : Crashed when system user was used for swift DLO operations
Status: CLOSED CURRENTRELEASE
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
2.3
Unspecified Unspecified
unspecified Severity urgent
: rc
: 3.0
Assigned To: Matt Benjamin (redhat)
ceph-qe-bugs
Erin Donnelly
:
Depends On:
Blocks: 1437916
  Show dependency treegraph
 
Reported: 2017-07-11 01:38 EDT by Vasishta
Modified: 2017-07-30 11:42 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
.Ceph Object Gateway crashes with Swift DLO operations The Ceph Object Gateway crashes when a system user attempts Swift DLO operations.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-18 10:59:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Contains RGW crash log snippet, secondary zone log snippet, terminal operations log snippet (15.06 KB, text/x-csrc)
2017-07-11 01:38 EDT, Vasishta
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 16072 None None None 2017-07-11 15:03 EDT

  None (edit)
Description Vasishta 2017-07-11 01:38:46 EDT
Created attachment 1296081 [details]
Contains RGW crash log snippet, secondary zone log snippet, terminal operations log snippet

Description of problem:
RGW crashed when a system user was used for swift DLO operation. The same user was used for s3 operations previously. The crash repeated again till a new user was created. Swift DLO operations worked fine with new users and resulted in error when tried again with the system user.

Version-Release number of selected component (if applicable):
ceph version 10.2.7-30redhat1xenial

How reproducible:
1/1

Steps to Reproduce:
1. Create a system user for RGW.
2. Perform swift DLO to upload a large file.

Actual results:

(Crash log snippet)
11: (RGWHTTPArgs::sys_get(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> > const&, bool*)+0x4c) [0x7fa954ecc47c]
 12: (RGWHandler_REST_SWIFT::authorize()+0x1b5) [0x7fa9550e8075]

-- (Error message after creating couple of users) --

('Connection aborted.', BadStatusLine("''",))

Expected results:
RGW shouldn't crash

Additional info:
Based on mail conversation I've set severity as 'urgent'. I'll try to reproduce the issue with higher log levels and update.
Comment 4 Vasishta 2017-07-11 03:21:34 EDT
Hi Matt,

I have tried basic swift DLO operations (upload & download) with non-system user and it had worked fine for me.
I restarted RGW service after it crashed because of using system user, and tried with ordinary user, which worked as expected.

Regards,
Vasishta

Note You need to log in before you can comment on or make changes to this bug.