Bug 1469407 - Fedora 26 ISO - Cannot select English (India) - pyanaconda.ui.gui.xkl_wrapper.XklWrapperError: Failed to replace layouts with: in (eng)
Summary: Fedora 26 ISO - Cannot select English (India) - pyanaconda.ui.gui.xkl_wrapper...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xkeyboard-config
Version: 26
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:3dab746169f71e0732ad28f45da...
: 1470742 1471462 1471483 1473898 1474041 1474355 1474359 1474776 1474934 1476449 1476855 1476874 1479722 1482199 1483069 1485454 1487011 1487904 1488160 1491041 1507867 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-07-11 08:42 UTC by Saurav Sengupta
Modified: 2017-11-15 16:21 UTC (History)
43 users (show)

Fixed In Version: xkeyboard-config-2.21-3.fc26 xkeyboard-config-2.21-3.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-15 22:22:10 UTC


Attachments (Terms of Use)
File: anaconda-tb (2.24 MB, text/plain)
2017-07-11 08:42 UTC, Saurav Sengupta
no flags Details
File: anaconda.log (48.46 KB, text/plain)
2017-07-11 08:42 UTC, Saurav Sengupta
no flags Details
File: environ (597 bytes, text/plain)
2017-07-11 08:42 UTC, Saurav Sengupta
no flags Details
File: journalctl (1017.72 KB, text/plain)
2017-07-11 08:43 UTC, Saurav Sengupta
no flags Details
File: lsblk_output (2.46 KB, text/plain)
2017-07-11 08:43 UTC, Saurav Sengupta
no flags Details
File: nmcli_dev_list (2.40 KB, text/plain)
2017-07-11 08:43 UTC, Saurav Sengupta
no flags Details
File: os_info (518 bytes, text/plain)
2017-07-11 08:43 UTC, Saurav Sengupta
no flags Details
File: program.log (176.72 KB, text/plain)
2017-07-11 08:43 UTC, Saurav Sengupta
no flags Details
File: storage.log (981.25 KB, text/plain)
2017-07-11 08:43 UTC, Saurav Sengupta
no flags Details
File: ifcfg.log (15.86 KB, text/plain)
2017-07-11 08:43 UTC, Saurav Sengupta
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1492981 None None None Never

Internal Links: 1492981

Description Saurav Sengupta 2017-07-11 08:42:31 UTC
Description of problem:
Trying to install Fedora 26, selecting English (India) in the first screen as the language for the installation and clicking the Continue button. The backtrace has a line saying that the corresponding (keyboard) layout could not be selected. This worked fine in the Fedora 26 Beta image.

Version-Release number of selected component:
anaconda-core-26.21.11-1.fc26.x86_64

The following was filed automatically by anaconda:
anaconda 26.21.11-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/xkl_wrapper.py", line 369, in replace_layouts
    raise XklWrapperError(msg)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/utils.py", line 77, in _call_method
    return func(*args, **kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/keyboard.py", line 363, in set_x_keyboard_defaults
    xkl_wrapper.replace_layouts(new_layouts)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/spokes/keyboard.py", line 331, in initialize
    keyboard.set_x_keyboard_defaults(self.data, self._xkl_wrapper)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 174, in _createBox
    spoke.initialize()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 370, in refresh
    self._createBox()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/ui/gui/__init__.py", line 1031, in _on_continue_clicked
    nextAction.refresh()
pyanaconda.ui.gui.xkl_wrapper.XklWrapperError: Failed to replace layouts with: in (eng)

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz root=live:CDLABEL=Fedora-WS-Live-26-1-5 rd.live.image quiet
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.11.8-300.fc26.x86_64
other involved packages: anaconda-gui-26.21.11-1.fc26.x86_64
product:        Fedora
release:        Fedora release 26 (Twenty Six)
type:           anaconda
version:        26

Comment 1 Saurav Sengupta 2017-07-11 08:42:48 UTC
Created attachment 1296125 [details]
File: anaconda-tb

Comment 2 Saurav Sengupta 2017-07-11 08:42:51 UTC
Created attachment 1296126 [details]
File: anaconda.log

Comment 3 Saurav Sengupta 2017-07-11 08:42:53 UTC
Created attachment 1296127 [details]
File: environ

Comment 4 Saurav Sengupta 2017-07-11 08:43:01 UTC
Created attachment 1296128 [details]
File: journalctl

Comment 5 Saurav Sengupta 2017-07-11 08:43:03 UTC
Created attachment 1296129 [details]
File: lsblk_output

Comment 6 Saurav Sengupta 2017-07-11 08:43:05 UTC
Created attachment 1296130 [details]
File: nmcli_dev_list

Comment 7 Saurav Sengupta 2017-07-11 08:43:07 UTC
Created attachment 1296131 [details]
File: os_info

Comment 8 Saurav Sengupta 2017-07-11 08:43:11 UTC
Created attachment 1296132 [details]
File: program.log

Comment 9 Saurav Sengupta 2017-07-11 08:43:19 UTC
Created attachment 1296133 [details]
File: storage.log

Comment 10 Saurav Sengupta 2017-07-11 08:43:21 UTC
Created attachment 1296134 [details]
File: ifcfg.log

Comment 11 Saurav Sengupta 2017-07-11 08:46:35 UTC
A workaround is to select English (United States) or English (United Kingdom) and then changing the keyboard layout and/or time zone in the next screen as required.

Comment 12 Saurav Sengupta 2017-07-11 09:12:20 UTC
Correction to comment #11: the keyboard layout still cannot be changed to English (India, with rupee) in the next screen. The time zone can, however, be changed to Asia/Kolkata, which is to be expected as this seems to concern the keyboard layout only.

Comment 13 Saurav Sengupta 2017-07-11 11:59:03 UTC
It is also not possible to select the English (India, with rupee) layout after installation - trying to do so crashes GNOME Shell and prevents further logins until the layout is erased from org.gnome.desktop.input-sources, sources. Currency signs can be added using GNOME Tweak Tool or by editing org.gnome.desktop.input-sources, xkb-options. Trying to select the layout in question in GNOME Initial Setup also creates the same problem. Trying to report the crash finds the duplicate bug #1398142.

Comment 14 Jiri Konecny 2017-07-14 08:11:37 UTC
*** Bug 1470742 has been marked as a duplicate of this bug. ***

Comment 15 Ravindra 2017-07-16 05:42:09 UTC
*** Bug 1471462 has been marked as a duplicate of this bug. ***

Comment 16 jomy john 2017-07-16 10:45:49 UTC
*** Bug 1471483 has been marked as a duplicate of this bug. ***

Comment 17 Nayeem 2017-07-22 07:33:32 UTC
*** Bug 1473898 has been marked as a duplicate of this bug. ***

Comment 18 Akshat Ahuja 2017-07-23 11:21:43 UTC
*** Bug 1474041 has been marked as a duplicate of this bug. ***

Comment 19 Deb 2017-07-24 12:52:00 UTC
*** Bug 1474355 has been marked as a duplicate of this bug. ***

Comment 20 Sachin Paliwal 2017-07-25 16:09:36 UTC
*** Bug 1474934 has been marked as a duplicate of this bug. ***

Comment 21 Mithra Talluri 2017-07-29 06:33:41 UTC
*** Bug 1476449 has been marked as a duplicate of this bug. ***

Comment 22 Pradeep Kumar 2017-07-31 16:51:51 UTC
*** Bug 1476874 has been marked as a duplicate of this bug. ***

Comment 23 Jiri Konecny 2017-08-01 08:48:57 UTC
*** Bug 1476855 has been marked as a duplicate of this bug. ***

Comment 24 vikram goyal 2017-08-09 09:32:06 UTC
*** Bug 1479722 has been marked as a duplicate of this bug. ***

Comment 25 Koustubh Sinkar 2017-08-16 17:21:19 UTC
*** Bug 1482199 has been marked as a duplicate of this bug. ***

Comment 26 Manoj Kunkalienkar 2017-08-18 17:25:26 UTC
*** Bug 1483069 has been marked as a duplicate of this bug. ***

Comment 27 Shivam Sharma 2017-08-25 18:48:26 UTC
*** Bug 1485454 has been marked as a duplicate of this bug. ***

Comment 28 harish.b 2017-08-31 04:42:39 UTC
*** Bug 1487011 has been marked as a duplicate of this bug. ***

Comment 29 Samantha N. Bueno 2017-09-04 08:10:13 UTC
*** Bug 1487904 has been marked as a duplicate of this bug. ***

Comment 30 Shashwata Rahut 2017-09-04 13:30:31 UTC
*** Bug 1488160 has been marked as a duplicate of this bug. ***

Comment 31 Vendula Poncova 2017-09-04 17:47:52 UTC
There is a missing comma in a configuration file. Then it works fine.

It was already fixed:
https://cgit.freedesktop.org/xkeyboard-config/commit/?id=b3fb72308942f705e3e8e17765e4097773ed5483

So it should be fine once xkeyboard-config-2.22 is released.

Comment 32 Fedora Update System 2017-09-04 22:56:57 UTC
xkeyboard-config-2.21-3.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-14b8509c71

Comment 33 Fedora Update System 2017-09-06 22:28:35 UTC
xkeyboard-config-2.21-3.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-14b8509c71

Comment 34 Fedora Update System 2017-09-10 13:59:44 UTC
xkeyboard-config-2.21-3.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e38be801d8

Comment 35 Fedora Update System 2017-09-10 18:23:51 UTC
xkeyboard-config-2.21-3.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e38be801d8

Comment 36 Saurav Sengupta 2017-09-12 05:19:31 UTC
The upgrade works fine on an installed system, but this still doesn't (understandably) resolve the issue in the Anaconda installer on the live image. A new ISO image with the upgrade included would help future installations.

Comment 37 Saurav Sengupta 2017-09-12 05:23:17 UTC
Also, it won't work in GNOME Initial Setup unless xkeyboard-config is upgraded first.

Comment 38 Jiri Konecny 2017-09-13 06:38:23 UTC
*** Bug 1491041 has been marked as a duplicate of this bug. ***

Comment 39 Debarshi Ray 2017-09-13 09:11:29 UTC
(In reply to Saurav Sengupta from comment #36)
> The upgrade works fine on an installed system, but this still doesn't
> (understandably) resolve the issue in the Anaconda installer on the live
> image. A new ISO image with the upgrade included would help future
> installations.

Fedora (famously) never issues updated installation images after the point-0 release.

Comment 40 Saurav Sengupta 2017-09-14 08:02:29 UTC
(In reply to Debarshi Ray from comment #39)
> Fedora (famously) never issues updated installation images after the point-0
> release.

At least the release notes/list of common bugs could be updated to inform users of this bug and the relevant upgrade which resolves it.

Comment 41 Martin Kolman 2017-09-14 09:53:00 UTC
(In reply to Saurav Sengupta from comment #40)
> (In reply to Debarshi Ray from comment #39)
> > Fedora (famously) never issues updated installation images after the point-0
> > release.
> 
> At least the release notes/list of common bugs could be updated to inform
> users of this bug and the relevant upgrade which resolves it.

CCing Petr Bokoc from the docs team.

Comment 42 Fedora Update System 2017-09-15 22:22:10 UTC
xkeyboard-config-2.21-3.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 43 Fedora Update System 2017-09-20 15:25:17 UTC
xkeyboard-config-2.21-3.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 44 Samantha N. Bueno 2017-09-21 10:49:45 UTC
*** Bug 1474359 has been marked as a duplicate of this bug. ***

Comment 45 Samantha N. Bueno 2017-09-21 10:49:52 UTC
*** Bug 1474776 has been marked as a duplicate of this bug. ***

Comment 46 Seshadri 2017-09-22 05:12:33 UTC
Similar problem has been detected:

Steps to reproduce:
1. Create VMware Workstation VM with Fedora-Xfce-Live-x86_64-26-1.5.iso
2. Boot to live environment and start install with "Install to Hard Drive" option.
3. Select English (India) and click Next.

Installation errors out.

Expected:
Install should move to next screen.

addons:         com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=vmlinuz initrd=initrd.img root=live:CDLABEL=Fedora-Xfce-Live-26-1-5 rd.live.image rd.live.check quiet
hashmarkername: anaconda
kernel:         4.11.8-300.fc26.x86_64
other involved packages: anaconda-gui-26.21.11-1.fc26.x86_64
package:        anaconda-core-26.21.11-1.fc26.x86_64
packaging.log:  
product:        Fedora
reason:         pyanaconda.ui.gui.xkl_wrapper.XklWrapperError: Failed to replace layouts with: in (eng)
release:        Fedora release 26 (Twenty Six)
version:        26

Comment 47 DG 2017-10-01 09:16:12 UTC
Similar problem has been detected:

I was trying to install FC26 on an already existing version which wasnt booting due to the error "Error in Parsing PCC subspaces from PCCT"

I was loading from a Live USB drive created using the Fedora Live USB creato on a Windows 10 64-bit OS. The machine for both is a Lenovo Thinkpad T450s

addons:         com_redhat_kdump
cmdline:        /usr/libexec/system-python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/images/pxeboot/vmlinuz root=live:CDLABEL=LIVE rd.live.image rd.live.check quiet
hashmarkername: anaconda
kernel:         4.11.8-300.fc26.x86_64
other involved packages: anaconda-gui-26.21.11-1.fc26.x86_64
package:        anaconda-core-26.21.11-1.fc26.x86_64
packaging.log:  
product:        Fedora
reason:         pyanaconda.ui.gui.xkl_wrapper.XklWrapperError: Failed to replace layouts with: in (eng)
release:        Fedora release 26 (Twenty Six)
version:        26

Comment 48 Kamil Páral 2017-10-31 11:06:24 UTC
*** Bug 1507867 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.