Bug 1469606 - [downstream clone - 4.1.4] rhvm-appliance only partitions 6gb for root partition
[downstream clone - 4.1.4] rhvm-appliance only partitions 6gb for root partition
Status: CLOSED DUPLICATE of bug 1469607
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-appliance (Show other bugs)
4.1.3
All Linux
urgent Severity urgent
: ovirt-4.1.4
: ---
Assigned To: Ryan Barry
Gonza
: Rebase, ZStream
Depends On: 1467946
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 10:31 EDT by Ryan Barry
Modified: 2017-07-11 10:36 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of: 1467946
Environment:
Last Closed: 2017-07-11 10:36:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ryan Barry 2017-07-11 10:31:10 EDT
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1467946 +++
======================================================================

Description of problem:


Version-Release number of selected component (if applicable):
rhvm-appliance-20170619.0-1.x86_64.rhevm.ova

How reproducible:
Every time.


Steps to Reproduce:
1. use `hosted-engine --deploy` on rhel host
2. use rhvm-appliance-4.1.20170619.0-1.el7.noarch.rpm to deploy manager VM
3. run out of disk space after about a week of logs and postgres data accumulation

Actual results:
anaconda.ks file has following entries for partitioning

[root@cloud ~]# cat anaconda-ks.cfg
...
bootloader --append="console=tty0" --location=mbr --timeout=1
# Clear the Master Boot Record
zerombr
# Partition clearing information
clearpart --all --initlabel 
# Disk partitioning information
part / --fstype="xfs" --ondisk=vda --size=6144
part swap --size=8192
...

[root@cloud ~]# lsblk 
NAME   MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
sr0     11:0    1 1024M  0 rom  
vda    253:0    0   75G  0 disk 
├─vda1 253:1    0    6G  0 part /
└─vda2 253:2    0    8G  0 part [SWAP]


Expected results:
'part /' line should include --grow by default, root partition should use full amount of available space.

Additional info:

(Originally by christopher.s.reynolds)
Comment 1 Ryan Barry 2017-07-11 10:31:19 EDT
growth is handled by cloud-utils-growpart

Since swap was added, cloud-utils-growpart will not grow the first partition, since swap abuts it.

These partitions are being reversed, so swap is first.

(Originally by Ryan Barry)
Comment 2 Ryan Barry 2017-07-11 10:31:25 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

(Originally by rule-engine)
Comment 4 Ryan Barry 2017-07-11 10:31:35 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

(Originally by rule-engine)
Comment 6 Ryan Barry 2017-07-11 10:31:46 EDT
Should this be ON_QA? Can you add it to the errata?

(Originally by Yaniv Dary)
Comment 7 Ryan Barry 2017-07-11 10:31:52 EDT
No -- it doesn't have 4.1.z+ yet, which is necessary to add it to the errata.

I also can't set the target version for appliance. I'll find someone who can.

(Originally by Ryan Barry)
Comment 8 Ryan Barry 2017-07-11 10:36:44 EDT

*** This bug has been marked as a duplicate of bug 1469607 ***

Note You need to log in before you can comment on or make changes to this bug.