Bug 1469607 - [downstream clone - 4.1.3] rhvm-appliance only partitions 6gb for root partition
[downstream clone - 4.1.3] rhvm-appliance only partitions 6gb for root partition
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhevm-appliance (Show other bugs)
4.1.3
All Linux
urgent Severity urgent
: ovirt-4.1.4
: ---
Assigned To: Ryan Barry
Gonza
: Rebase, ZStream
: 1469606 1571233 (view as bug list)
Depends On: 1467946
Blocks:
  Show dependency treegraph
 
Reported: 2017-07-11 10:33 EDT by rhev-integ
Modified: 2018-04-25 08:16 EDT (History)
16 users (show)

See Also:
Fixed In Version: rhvm-appliance-20170710.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1467946
Environment:
Last Closed: 2017-07-27 14:04:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 79055 master MERGED engine-appliance: make swap partition first 2017-07-11 10:33 EDT
oVirt gerrit 79067 ovirt-4.1 MERGED engine-appliance: make swap partition first 2017-07-11 10:33 EDT
oVirt gerrit 79069 ovirt-4.1-pre MERGED engine-appliance: make swap partition first 2017-07-11 10:33 EDT
oVirt gerrit 79070 ovirt-4.1-snapshot MERGED engine-appliance: make swap partition first 2017-07-11 10:33 EDT
Red Hat Product Errata RHEA-2017:1817 normal SHIPPED_LIVE rhvm-appliance bug fix and enhancement update for RHV 4.1 2017-07-27 17:59:53 EDT

  None (edit)
Description rhev-integ 2017-07-11 10:33:09 EDT
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1467946 +++
======================================================================

Description of problem:


Version-Release number of selected component (if applicable):
rhvm-appliance-20170619.0-1.x86_64.rhevm.ova

How reproducible:
Every time.


Steps to Reproduce:
1. use `hosted-engine --deploy` on rhel host
2. use rhvm-appliance-4.1.20170619.0-1.el7.noarch.rpm to deploy manager VM
3. run out of disk space after about a week of logs and postgres data accumulation

Actual results:
anaconda.ks file has following entries for partitioning

[root@cloud ~]# cat anaconda-ks.cfg
...
bootloader --append="console=tty0" --location=mbr --timeout=1
# Clear the Master Boot Record
zerombr
# Partition clearing information
clearpart --all --initlabel 
# Disk partitioning information
part / --fstype="xfs" --ondisk=vda --size=6144
part swap --size=8192
...

[root@cloud ~]# lsblk 
NAME   MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
sr0     11:0    1 1024M  0 rom  
vda    253:0    0   75G  0 disk 
├─vda1 253:1    0    6G  0 part /
└─vda2 253:2    0    8G  0 part [SWAP]


Expected results:
'part /' line should include --grow by default, root partition should use full amount of available space.

Additional info:

(Originally by christopher.s.reynolds)
Comment 1 rhev-integ 2017-07-11 10:33:18 EDT
growth is handled by cloud-utils-growpart

Since swap was added, cloud-utils-growpart will not grow the first partition, since swap abuts it.

These partitions are being reversed, so swap is first.

(Originally by Ryan Barry)
Comment 3 rhev-integ 2017-07-11 10:33:23 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

(Originally by rule-engine)
Comment 5 rhev-integ 2017-07-11 10:33:33 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

(Originally by rule-engine)
Comment 7 rhev-integ 2017-07-11 10:33:43 EDT
Should this be ON_QA? Can you add it to the errata?

(Originally by Yaniv Dary)
Comment 8 rhev-integ 2017-07-11 10:33:48 EDT
No -- it doesn't have 4.1.z+ yet, which is necessary to add it to the errata.

I also can't set the target version for appliance. I'll find someone who can.

(Originally by Ryan Barry)
Comment 9 Ryan Barry 2017-07-11 10:36:44 EDT
*** Bug 1469606 has been marked as a duplicate of this bug. ***
Comment 11 Avital Pinnick 2017-07-13 08:18:51 EDT
Added doc text and set RDT flag to '+'
Comment 12 Gonza 2017-07-18 04:45:35 EDT
Verified with:
rhvm-appliance-20170709.3-1.x86_64.rhevm.ova

# lsblk
NAME   MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
sr0     11:0    1 1024M  0 rom  
sr1     11:1    1  374K  0 rom  
vda    253:0    0   58G  0 disk 
├─vda1 253:1    0    8G  0 part [SWAP]
└─vda2 253:2    0   50G  0 part /
Comment 13 Avital Pinnick 2017-07-20 09:12:06 EDT
Ryan,

Could you please clarify? Does this bug need doc text?
Comment 14 Ryan Barry 2017-07-20 09:13:27 EDT
No, this is a side effect of adding swap to the appliance. Relevant doc text was there.
Comment 16 errata-xmlrpc 2017-07-27 14:04:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1817
Comment 17 Ryan Barry 2018-04-25 08:16:24 EDT
*** Bug 1571233 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.