Bug 1469776 - fails to run on first boot after KDE install with ModuleNotFoundError: No module named 'pyanaconda.threads'
fails to run on first boot after KDE install with ModuleNotFoundError: No mod...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initial-setup (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Martin Kolman
Fedora Extras Quality Assurance
:
Depends On:
Blocks: AlphaBlocker/F27AlphaBlocker
  Show dependency treegraph
 
Reported: 2017-07-11 15:51 EDT by Adam Williamson
Modified: 2017-07-24 21:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-24 21:16:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2017-07-11 15:51:10 EDT
Similar to https://bugzilla.redhat.com/show_bug.cgi?id=1463960 for anaconda, but for initial-setup.

On current Rawhide, if you install from the KDE live image and do not create a user during installation, initial-setup should run on the first boot, but it does not. In the journal, you can see these errors:

Jul 10 16:47:02 localhost.localdomain initial-setup[824]: initializing the Anaconda log
Jul 10 16:47:02 localhost.localdomain initial-setup[824]: initializing threading
Jul 10 16:47:02 localhost.localdomain initial-setup[824]: Initial Setup crashed due to unhandled exception:
                                                          Traceback (most recent call last):
                                                            File "/usr/libexec/initial-setup/initial-setup-graphical", line 5, in <module>
                                                              is_instance = InitialSetup(gui_mode=True)
                                                            File "/usr/lib/python3.6/site-packages/initial_setup/__init__.py", line 141, in __init__
                                                              from pyanaconda.threads import initThreading
                                                          ModuleNotFoundError: No module named 'pyanaconda.threads'
Jul 10 16:47:02 localhost.localdomain initial-setup[982]: Stopping the window manager (/usr/bin/kwin_x11)

This probably also affects the ARM disk image (where initial-setup must run on first boot or else the system is unusable), so nominating as an Alpha blocker per criterion "A working mechanism to create a user account must be clearly presented during installation and/or first boot of the installed system."
Comment 1 Martin Kolman 2017-07-12 06:34:28 EDT
This should be fixed in 0.3.48 - but the build fails due to some unrelated s390 breakage:
https://koji.fedoraproject.org/koji/taskinfo?taskID=20474257

I'll be on PTO from today afternoon so someone else will have to do the build once the s390 stuff is fixed.
Comment 2 Adam Williamson 2017-07-24 21:16:58 EDT
I've sent the build now: https://koji.fedoraproject.org/koji/buildinfo?buildID=917785 . I'll go ahead and close this, openQA will verify with the next compose; I'll re-open if it's somehow still busted.

Note You need to log in before you can comment on or make changes to this bug.