Bug 1469800 - package profile task runs profile update and generate applicability at the same time [NEEDINFO]
package profile task runs profile update and generate applicability at the sa...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management (Show other bugs)
6.2.0
Unspecified Unspecified
high Severity high (vote)
: 6.2.13
: --
Assigned To: Eric Helms
jcallaha
: Triaged
: 1490924 1494908 (view as bug list)
Depends On:
Blocks: 1499936
  Show dependency treegraph
 
Reported: 2017-07-11 17:01 EDT by Eric Helms
Modified: 2018-03-29 09:44 EDT (History)
19 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.157-1
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1499936 (view as bug list)
Environment:
Last Closed: 2017-10-12 13:43:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
lzap: needinfo? (ehelms)


Attachments (Terms of Use)
6.2.11 patch (1.11 KB, patch)
2017-09-12 15:17 EDT, Justin Sherrill
no flags Details | Diff
screenshot 1 (78.00 KB, image/png)
2017-10-10 14:53 EDT, jcallaha
no flags Details
screenshot 2 (43.31 KB, image/png)
2017-10-10 14:53 EDT, jcallaha
no flags Details
screenshot 3 (80.66 KB, image/png)
2017-10-10 14:53 EDT, jcallaha
no flags Details
verification screenshot (85.53 KB, image/png)
2017-10-10 14:54 EDT, jcallaha
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 20280 None None None 2017-07-11 17:01 EDT

  None (edit)
Description Eric Helms 2017-07-11 17:01:07 EDT
Currently Actions::KatellO::Host::UploadPackageProfile  is running purely concurrently, meaning that the profile update and the kickoff of the applicability generation could occur in the wrong order
Comment 1 Eric Helms 2017-07-11 17:01:10 EDT
Created from redmine issue http://projects.theforeman.org/issues/20280
Comment 2 Eric Helms 2017-07-11 17:01:16 EDT
Upstream bug assigned to ehelms@redhat.com
Comment 4 pm-sat@redhat.com 2017-07-12 22:15:09 EDT
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/20280 has been resolved.
Comment 5 pm-sat@redhat.com 2017-08-03 18:18:12 EDT
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/20280 has been resolved.
Comment 6 Justin Sherrill 2017-09-12 15:17 EDT
Created attachment 1325001 [details]
6.2.11 patch
Comment 7 Brad Buckingham 2017-09-20 17:10:23 EDT
*** Bug 1490924 has been marked as a duplicate of this bug. ***
Comment 8 Lukas Zapletal 2017-09-21 11:14:16 EDT
Thanks, super annoying :-)
Comment 9 Brad Buckingham 2017-09-28 16:43:32 EDT
*** Bug 1494908 has been marked as a duplicate of this bug. ***
Comment 11 jcallaha 2017-10-10 14:52:35 EDT
Verified in Satellite 6.2.12 Snap 6.

Registered a RHEL 7.2 system which initially showed 22 sec, 11 bug, and 17 enhancement errata (screenshot 1). 
I then applied 3 bug fix errata (screenshot 2). 
After that successfully completed, I then navigated back to the details page for the content host and refreshed the page. The errata count was successfully updated with the correct results (screenshot 3).

'verification screenshot' shows the upload package profile starting and completing before the generate applicability task is kicked off.
Comment 12 jcallaha 2017-10-10 14:53 EDT
Created attachment 1336880 [details]
screenshot 1
Comment 13 jcallaha 2017-10-10 14:53 EDT
Created attachment 1336881 [details]
screenshot 2
Comment 14 jcallaha 2017-10-10 14:53 EDT
Created attachment 1336882 [details]
screenshot 3
Comment 15 jcallaha 2017-10-10 14:54 EDT
Created attachment 1336883 [details]
verification screenshot
Comment 16 Lukas Zapletal 2017-10-11 03:16:27 EDT
This bug was aligned into 6.2.13 why are we testing 6.2.12 snap? Is this going to be released in 6.2.12 then? Thanks.
Comment 20 errata-xmlrpc 2017-10-12 13:43:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2887

Note You need to log in before you can comment on or make changes to this bug.