Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 1470048 - Rebase samba in RHEL-7.5 to version 4.7.x
Rebase samba in RHEL-7.5 to version 4.7.x
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba (Show other bugs)
7.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Andreas Schneider
Andrej Dzilský
Marc Muehlfeld
: Rebase
Depends On: 1470049 1470053 1470054 1470056
Blocks: 1472344
  Show dependency treegraph
 
Reported: 2017-07-12 06:49 EDT by Andreas Schneider
Modified: 2018-04-10 13:29 EDT (History)
8 users (show)

See Also:
Fixed In Version: samba-4.7.0-1.el7
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Samba rebased to version 4.7.1 The _samba_ packages have been upgraded to upstream version 4.7.1, which provides a number of bug fixes and enhancements over the previous version. Notable changes include: * Previously, the default value of the "rpc server dynamic port range" parameter was "1024-1300". With this update, the default has been changed to "49152-65535" and now matches the range used in Windows Server 2008 and later. Update your firewall rules if necessary. * Samba now uses the Advanced Encryption Standard (AES) instruction set of Intel CPUs to accelerate Server Message Block (SMB) 3 signing and encryption operations. * The options of the "ntlm auth" parameter have been extended. The parameter now accepts the "ntlmv2-only" (alias "no"), "ntlmv1-permitted" (alias "yes"), "mschapv2-and-ntlmv2-only", and "disabled" options. Additionally, the default value was renamed from "no" to "ntlmv2-only". * The "smbclient" utility no longer displays a banner with the domain, operating system, and server version when connecting to a server. * The default value of the "client max protocol" parameter has been changed to "SMB3_11". This enables utilities, such as "smbclient", to connect to servers using the SMB 3.11 protocol without setting the protocol version. * For a better interoperability, Samba no longer supports using mixed minor versions in a *CTDB* cluster. Samba automatically updates its tdb database files when the "smbd", "nmbd", or "winbind" daemon starts. Back up the database files before starting Samba. Note that Red Hat does not support downgrading tdb database files. For further information about notable changes, read the upstream release notes before updating: * https://www.samba.org/samba/history/samba-4.7.0.html
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 13:28:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0937 None None None 2018-04-10 13:29 EDT

  None (edit)
Description Andreas Schneider 2017-07-12 06:49:09 EDT
Besides including all the latest upstream bugfixes and interoperability improvements the new Samba version has MIT Kerberos support for AD and supports the new printing protocol MS-PAR (winspool).
Comment 10 errata-xmlrpc 2018-04-10 13:28:22 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0937

Note You need to log in before you can comment on or make changes to this bug.