Bug 1470157 - symbolic links are broken
symbolic links are broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: supermin (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard W.M. Jones
Fedora Extras Quality Assurance
:
: 1470375 1534616 (view as bug list)
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs 1494859
  Show dependency treegraph
 
Reported: 2017-07-12 09:10 EDT by Richard W.M. Jones
Modified: 2018-01-15 10:50 EST (History)
14 users (show)

See Also:
Fixed In Version: supermin-5.1.18-1.fc26 supermin-5.1.18-1.fc25
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-28 13:19:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log from libguestfs-test-tool (29.58 KB, text/plain)
2017-07-12 09:11 EDT, Richard W.M. Jones
no flags Details

  None (edit)
Description Richard W.M. Jones 2017-07-12 09:10:08 EDT
Description of problem:

Hard as it is to believe, the symbolic links appear to be broken
in kernel-4.13.0-0.rc0.git4.1.fc27.x86_64.  They are NOT broken in
the immediately preceeding kernel
(kernel-4.13.0-0.rc0.git3.1.fc27.x86_64).

In supermin we run a small init process, source is here:
https://github.com/libguestfs/supermin/blob/master/init/init.c#L482

With the broken kernel, when displaying the root directory, we
see strangely broken links:

supermin: debug: listing directory /
  205 d boot             040555 4096 0:0
  597 d proc             040555 4096 0:0
  198 - init             100755 6643 1000:1000
  174 d usr              040755 4096 1000:1000
    2 d ..               040755 4096 0:0
  594 d media            040755 4096 0:0
  632 d tmp              041777 4096 0:0
  206 d dev              040755 4096 0:0
  531 d home             040755 4096 0:0
  630 d srv              040755 4096 0:0
  534 l lib64            120777 9 0:0 -> \xe9\x11
 9044 d var              040755 4096 0:0
  604 l sbin             120777 8 0:0 -> \x5\x18
  599 d run              040755 4096 0:0
    2 d .                040755 4096 0:0
  200 l bin              120777 7 0:0 -> M\b
  598 d root             040550 4096 0:0
  631 d sys              040555 4096 0:0
   12 d etc              040755 4096 1000:1000
   11 d lost+found       040700 16384 0:0
  532 l lib              120777 7 0:0 -> \xe7\x11
  596 d opt              040755 4096 0:0
  595 d mnt              040755 4096 0:0
supermin: debug: listing directory /bin
/bin: No such file or directory
supermin: debug: listing directory /lib
/lib: No such file or directory
supermin: debug: listing directory /lib64
/lib64: No such file or directory


Version-Release number of selected component (if applicable):

Broken in:
kernel-4.13.0-0.rc0.git4.1.fc27.x86_64
Working in:
kernel-4.13.0-0.rc0.git3.1.fc27.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Run libguestfs-test-tool with the latest kernel installed.

Additional info:

Full output attached.
Comment 1 Richard W.M. Jones 2017-07-12 09:11 EDT
Created attachment 1296975 [details]
log from libguestfs-test-tool
Comment 2 Richard W.M. Jones 2017-07-12 09:26:23 EDT
Also broken in kernel-4.13.0-0.rc0.git5.1.fc27.x86_64
Comment 3 Richard W.M. Jones 2017-07-12 10:37:51 EDT
This is reproducible with the current upstream kernel, but not with
v4.12 tag.  Am currently bisecting ...
Comment 4 Richard W.M. Jones 2017-07-12 12:12:33 EDT
407cd7fb83c0ebabb490190e673d8c71ee7df97e is the first bad commit
commit 407cd7fb83c0ebabb490190e673d8c71ee7df97e
Author: Tahsin Erdogan <tahsin@google.com>
Date:   Tue Jul 4 00:11:21 2017 -0400

    ext4: change fast symlink test to not rely on i_blocks
    
    ext4_inode_info->i_data is the storage area for 4 types of data:
    
      a) Extents data
      b) Inline data
      c) Block map
      d) Fast symlink data (symlink length < 60)
    
    Extents data case is positively identified by EXT4_INODE_EXTENTS flag.
    Inline data case is also obvious because of EXT4_INODE_INLINE_DATA
    flag.
    
    Distinguishing c) and d) however requires additional logic. This
    currently relies on i_blocks count. After subtracting external xattr
    block from i_blocks, if it is greater than 0 then we know that some
    data blocks exist, so there must be a block map.
    
    This logic got broken after ea_inode feature was added. That feature
    charges the data blocks of external xattr inodes to the referencing
    inode and so adds them to the i_blocks. To fix this, we could subtract
    ea_inode blocks by iterating through all xattr entries and then check
    whether remaining i_blocks count is zero. Besides being complicated,
    this won't change the fact that the current way of distinguishing
    between c) and d) is fragile.
    
    The alternative solution is to test whether i_size is less than 60 to
    determine fast symlink case. ext4_symlink() uses the same test to decide
    whether to store the symlink in i_data. There is one caveat to address
    before this can work though.
    
    If an inode's i_nlink is zero during eviction, its i_size is set to
    zero and its data is truncated. If system crashes before inode is removed
    from the orphan list, next boot orphan cleanup may find the inode with
    zero i_size. So, a symlink that had its data stored in a block may now
    appear to be a fast symlink. The solution used in this patch is to treat
    i_size = 0 as a non-fast symlink case. A zero sized symlink is not legal
    so the only time this can happen is the mentioned scenario. This is also
    logically correct because a i_size = 0 symlink has no data stored in
    i_data.
    
    Suggested-by: Andreas Dilger <adilger@dilger.ca>
    Signed-off-by: Tahsin Erdogan <tahsin@google.com>
    Signed-off-by: Theodore Ts'o <tytso@mit.edu>
    Reviewed-by: Andreas Dilger <adilger@dilger.ca>

:040000 040000 31b0eecd7314c483ed78346637ebb6a85c49741b 47a1dbadb0203d7f7d233224d47c5889ab22fc4f M	fs
Comment 5 Laura Abbott 2017-07-12 12:28:07 EDT
Thanks for the bisect! I haven't seen this reported on the ext4 mailing list so your best bet is to e-mail that list directly.
Comment 6 Richard W.M. Jones 2017-07-12 12:41:19 EDT
Actually I think I'm going to blame supermin for creating fast symlinks
wrong.  For the full explanation see:

https://www.redhat.com/archives/libguestfs/2017-July/msg00078.html

It's an open question if the kernel wants to support the "fast
symlinks stored slow" or if that is considered to be an erroneous
filesystem.
Comment 7 Richard W.M. Jones 2017-07-12 16:51:47 EDT
*** Bug 1470375 has been marked as a duplicate of this bug. ***
Comment 8 David Hill 2017-07-12 17:56:56 EDT
How can I tell supermin to use 4.12 kernel?
Comment 9 David Hill 2017-07-12 18:01:16 EDT
(In reply to David Hill from comment #8)
> How can I tell supermin to use 4.12 kernel?

 export SUPERMIN_KERNEL=/path/to/linux.git/arch/x86/boot/bzImage
 export SUPERMIN_MODULES=/tmp/kmods/lib/modules/3.xx.yy
Comment 10 David Hill 2017-07-12 18:02:53 EDT
I've tried using the previous 4.11.0-1 kernel and it worked as previously.
Comment 11 Richard W.M. Jones 2017-07-13 03:41:52 EDT
(In reply to David Hill from comment #9)
> (In reply to David Hill from comment #8)
> > How can I tell supermin to use 4.12 kernel?
> 
>  export SUPERMIN_KERNEL=/path/to/linux.git/arch/x86/boot/bzImage
>  export SUPERMIN_MODULES=/tmp/kmods/lib/modules/3.xx.yy

export SUPERMIN_KERNEL=/boot/vmlinuz-4.11.6-300.fc26.x86_64
export SUPERMIN_MODULES=/lib/modules/4.11.6-300.fc26.x86_64
rm -rf /var/tmp/.guestfs-*
Comment 12 Richard W.M. Jones 2017-07-13 03:54:43 EDT
v2 posted:
https://www.redhat.com/archives/libguestfs/2017-July/msg00084.html
Comment 13 Richard W.M. Jones 2017-07-13 03:59:19 EDT
Upstream discussion of the kernel/ext4 issues:
https://marc.info/?l=linux-ext4&m=149987925520576&w=2
Click ‘Subject: Fast symlinks stored slow’ to see the full thread.
Comment 14 Fedora Update System 2017-07-13 07:09:58 EDT
supermin-5.1.18-1.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f6b14e0e63
Comment 15 Fedora Update System 2017-07-13 07:10:17 EDT
supermin-5.1.18-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-e587cfd70e
Comment 16 Richard W.M. Jones 2017-07-13 07:11:36 EDT
(In reply to David Hill from comment #10)
> I've tried using the previous 4.11.0-1 kernel and it worked as previously.

There are new supermin builds for Fedora 25, 26 and Rawhide, please
see if one of those works with the latest kernel:

https://koji.fedoraproject.org/koji/packageinfo?packageID=15420
Comment 17 David Hill 2017-07-13 09:58:15 EDT
This looks promising.  I've removed my exports and retried and it booted.  I'll try another build that I didn't modify and come back later on today.
Comment 18 Fedora Update System 2017-07-13 17:25:53 EDT
supermin-5.1.18-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-e587cfd70e
Comment 19 Fedora Update System 2017-07-13 19:53:35 EDT
supermin-5.1.18-1.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f6b14e0e63
Comment 20 Fedora Update System 2017-07-28 13:19:07 EDT
supermin-5.1.18-1.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2017-07-28 16:49:20 EDT
supermin-5.1.18-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 26 Richard W.M. Jones 2017-11-03 07:26:13 EDT
If you are looking for an update supermin5 package for RHEL 7, see:

https://www.redhat.com/archives/libguestfs/2017-November/msg00006.html
"Libguestfs for RHEL 7.5 preview repository"
Comment 27 Richard W.M. Jones 2018-01-15 10:50:04 EST
*** Bug 1534616 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.